locked
VS 2005 - Microsoft Visual SourceSafe source control Probelm

    Question

  • Hi all,

     

    Everytime I try and use my Source Control I'm faced with the following error message:

     

    There was a failure while initializing the Microsoft Visual SourceSafe source control provider. You cannot use this provider to perform source control operations.

     

    When I click the help button I receive the follwoing information,

     

    This message is displayed when a source control operation cannot be completed and Visual Studio cannot determine the precise cause of the error.

    Things to check:

    • Security settings   Do you have sufficient access rights to open a source control database?

    • Network connectivity   Are you still connected to the network? Is the source control server available on the network?

    • Source control integration   Have you completely and correctly installed the named source control provider?

    I have the correct security access rights.

    I am connected to a network.

    The installation is straight foward, don't think I did something wrong.

     

    Can anyone please help me ??

     

    Many Thanx.

    Regards,

    Tuesday, April 10, 2007 10:19 AM

Answers

  • hi, I got the same problem with you. And finally I resolved it like following:

    1. Open VS2005, then choose the menu:
    Tools->Options, then click "Souce Control"
    2. click drop-down box under text"Current souce control plug-in", use "None", rather then "Microsoft Visual Source Safe"
    Monday, May 14, 2007 12:34 PM

All replies

  • Hi,

    The most possible cause of this problem is a missing dependency binary on the machine. Can you please try reinstalling/repairing VSS on the machine?

     

    Thanks,

    Nitin

    Thursday, April 19, 2007 11:20 PM
    Moderator
  • Hi,

    I have the same problem, so, i did reinstall vss on the machine and the problem persist, my problem begin when i did try install visual studio 6 and failure, help =S

    Thanks.

    Sunday, April 29, 2007 8:09 PM
  • i'm also haveing the same problem. i have reistalled VSS, and the IDE, with no luck

     

    Please help

    Kevin@oandp.com

    Tuesday, May 01, 2007 3:23 PM
  • I've randomly started having this same problem.
    Thursday, May 03, 2007 5:09 AM
  • I am having this problem as well. I am using Source Safe 6.0d Build 9848 It worked correctly before and now when I moved the setup to my new machine it keeps reporting:

    "
    There was a failure while initializing the Microsoft Visual SourceSafe source control provider. You cannot use this provider to perform source control operations."

    Any help, other then "re-installation", would be greatly appreciated...
    Monday, May 07, 2007 2:18 PM
  • hi, I got the same problem with you. And finally I resolved it like following:

    1. Open VS2005, then choose the menu:
    Tools->Options, then click "Souce Control"
    2. click drop-down box under text"Current souce control plug-in", use "None", rather then "Microsoft Visual Source Safe"
    Monday, May 14, 2007 12:34 PM
  • I'm not sure if this was a joke or not, but all this appears to do is remove the option to "Open form from source control..." from the IDE.
    Tuesday, May 15, 2007 9:10 PM
  • i'm currently getting the same error.. and another thing is, the "Open form from source control" is no longer on my VS 2003..

    i'll try to reinstall VSS hopefully i can get any luck!
    Thursday, May 17, 2007 8:06 AM
  •  

    Hey!!!

    I dont know if it will work for you or not. I got this error and i tried lot of things. Later i read this and got some idea regarding security. I had VSS user id same as my window login user. But passwords were different. I changed my VSS DB's password and made it same as my windows login's password.

     

     

    It worked. Smile

    Thursday, February 14, 2008 9:08 AM
  • I get this message too often and this is what I have to do each time (there may be a more elagant way but this works for me).  BTW, I am currently using VS 2008 Professional and PVCS for source code control.

     

    1) Back up your workfile folders to ensure you don't lose any recent work

    2) Open Visual Studio clean (no solutions loaded). If you are configured to automatically load your last solution, you may want to change your preferences.

    3) Go into File / Source Control / Open From Source Control

    4) Allow it to overwrite any / all files.

    5) I usually get some message about the previous user not binding the solution correctly and instructing me to go into File / Source Control / Change Source Control and correct the binding (I think that is the message). Anyway, I go in there and find the code is already properly bound (binded ?).

    6) After that, shutdown VS and reopen it. Usually I can open my project without any errors.

    7) At this point, if you had any recent work that was overwritten in the process, make sure it is "checked out" in Visual Studio and then copy the updated files from your backup in step 1 above over the older file that was restored from Source Control. You will need to check the files back into Source Control to ensure the Source Control repository is up to date.

     

    I hope this helps someone.

     

    Ken 

     

    Friday, February 15, 2008 3:36 PM
  •  

    My problem is that in the File menu the Source Control menu cant be seen.

    When opening the solution following message is shown

     

    The project appears to be under source control, but no source control provider is installed on this computer. Source control integration will be disabled for this project.

     

    But VSS is installed on my system and I m unable to work in the unbound mode with the VSS

     

    Thanks and Regards

    Pooja

    Tuesday, February 19, 2008 7:32 AM
  • Pooja,

     

    Referring back to the list of steps I posted, try and open Visual Studio clean (without any solutions loaded) and see if the Source Control menu can be seen. If it can, then back up your working folder on your workstation and try to open the solution from VSS (not from links to recent projects).

     

    Thanks,

     

    Ken

     

    Tuesday, February 19, 2008 1:01 PM
  • Hi Pooja, hope tat you will see this post.

    I am facing the same issue now and I can't find the way how to open a solution from the VSS...

     

    Thanks,

    Oren

    Tuesday, April 22, 2008 9:08 AM
  • Hello all,

    I had the same issue but found VSS2005 update here http://support.microsoft.com/kb/943847. Installed it and voila - now it works!

     

    Hope this works for you all.

     

    Wednesday, April 30, 2008 6:07 PM

  • Hi,
    Here u check ur installed path of VSS is correct or not. If ur path is not correct then go to "start -> run ->"regsvr32
     (modified path) \SSSCC.DLL"

    I hope it will work in this situation.
    Thursday, May 08, 2008 8:20 AM
  •  

    Sandeep,

     

    Thanks for the tip!  I'm running VSS 6.0 and VS 2003 and was having the same issue as some of the people posting here; File --> Source Control menu option was not showing up at all.  After registering the VSS dll it appeared and everything works great!

     

    Thanks,

    Hasty.

    Thursday, May 15, 2008 11:36 PM
  • Ha, so simple - same error happened after renaming the VSS directory under C:\Program Files\Microsoft Visual Studio\. Renamed it back to "VSS" and everything is honky-donkey again.
    Monday, September 08, 2008 5:10 PM
  • tjsailor said:

    hi, I got the same problem with you. And finally I resolved it like following:

    1. Open VS2005, then choose the menu:
    Tools->Options, then click "Souce Control"
    2. click drop-down box under text"Current souce control plug-in", use "None", rather then "Microsoft Visual Source Safe"

    In spite of what Variables said back in 2007 in the message following yours, your suggestion worked for me. Thank you for the help.

    Tuesday, October 28, 2008 6:42 PM
  • Hi Sandeep,

    This solved my problem too..

    Thanks, 
    Rao


    P.K.Rao
    Friday, November 21, 2008 5:07 PM
  • Sandeep's suggestion is indeed a good one! Thanks, man.

    Here I reiterate what we've just done here at work:
    - In VS2003, menu item File->Source Control wasn't showing up at all (VS wouldn't work with VSS, failed to open solution, etc)
    - We registered SSSCC.dll
    - The menu item in VS showed up, problem with opening solution were gone.

    NICE!!
    Thursday, April 30, 2009 6:19 PM
  • I've got the same problem, i.e. I'm using VSS 6.0d with VS2005.  It was working fine, now after rebuilding my machine after a virus attack I'm getting the above error.  I've since reinstalled VSS, but the error persists.

    The only thing selecting "None" as the Source Control plug-in does is remove VSS control from the project.  It DOES NOT solve the problem.

    Wednesday, September 23, 2009 6:07 PM
  • Anybody can help me?

    I am using Visual Studio 2008. I'm working with camera. At first program, A can detect my camera. And the applicatpion working good. After a while, I am access my program again, but there is error message, and the program stop immediately. So I turn off my VB and open VS 2008 again. But A got a message 

     

    There was a failure while initializing the Microsoft Visual SourceSafe source control provider. You cannot use this provider to perform source control operations.

     

    And after I run my program again, there are any message:

     

    An unhandled exception of type 'System.InvalidOperationException' occurred in Basic Computer Vision.exe

    Additional information: An error occurred creating the form. See Exception.InnerException for details.  The error is: Error: Unable to create capture from camera0

     

    And, at output message

     

    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_32\mscorlib\2.0.0.0__b77a5c561934e089\mscorlib.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\Microsoft.VisualStudio.HostingProcess.Utilities\9.0.0.0__b03f5f7f11d50a3a\Microsoft.VisualStudio.HostingProcess.Utilities.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Windows.Forms\2.0.0.0__b77a5c561934e089\System.Windows.Forms.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System\2.0.0.0__b77a5c561934e089\System.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Drawing\2.0.0.0__b03f5f7f11d50a3a\System.Drawing.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\Microsoft.VisualStudio.HostingProcess.Utilities.Sync\9.0.0.0__b03f5f7f11d50a3a\Microsoft.VisualStudio.HostingProcess.Utilities.Sync.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\Microsoft.VisualStudio.Debugger.Runtime\9.0.0.0__b03f5f7f11d50a3a\Microsoft.VisualStudio.Debugger.Runtime.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'E:\Kuliah S2\Semester 2\Computer Based Visual Perception\Poject Basic\Basic Computer Vision\Basic Computer Vision\bin\Debug\Basic Computer Vision.vshost.exe'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_32\System.Data\2.0.0.0__b77a5c561934e089\System.Data.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Deployment\2.0.0.0__b03f5f7f11d50a3a\System.Deployment.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Xml\2.0.0.0__b77a5c561934e089\System.Xml.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Core\3.5.0.0__b77a5c561934e089\System.Core.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Xml.Linq\3.5.0.0__b77a5c561934e089\System.Xml.Linq.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Data.DataSetExtensions\3.5.0.0__b77a5c561934e089\System.Data.DataSetExtensions.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\Microsoft.VisualBasic\8.0.0.0__b03f5f7f11d50a3a\Microsoft.VisualBasic.dll'
    The thread 0xe5c has exited with code 0 (0x0).
    The thread 0xea8 has exited with code 0 (0x0).
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'E:\Kuliah S2\Semester 2\Computer Based Visual Perception\Poject Basic\Basic Computer Vision\Basic Computer Vision\bin\Debug\Basic Computer Vision.exe', Symbols loaded.
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Runtime.Remoting\2.0.0.0__b77a5c561934e089\System.Runtime.Remoting.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'E:\Kuliah S2\Semester 2\Computer Based Visual Perception\Poject Basic\Basic Computer Vision\Basic Computer Vision\bin\Debug\Emgu.CV.dll'
    'Basic Computer Vision.vshost.exe' (Managed): Loaded 'E:\Kuliah S2\Semester 2\Computer Based Visual Perception\Poject Basic\Basic Computer Vision\Basic Computer Vision\bin\Debug\Emgu.Util.dll'
    A first chance exception of type 'System.NullReferenceException' occurred in Emgu.CV.dll
    A first chance exception of type 'System.Reflection.TargetInvocationException' occurred in mscorlib.dll
    A first chance exception of type 'System.InvalidOperationException' occurred in Basic Computer Vision.exe
    An unhandled exception of type 'System.InvalidOperationException' occurred in Basic Computer Vision.exe

    Additional information: An error occurred creating the form. See Exception.InnerException for details.  The error is: Error: Unable to create capture from camera0

    The thread 0xa94 has exited with code 0 (0x0).
    The program '[3280] Basic Computer Vision.vshost.exe: Managed' has exited with code -532459699 (0xe0434f4d).

     

    Thanks

    Saturday, November 13, 2010 12:50 PM
  • I had the same problem with Visual Studio 2008 and Sourcesafe 6.0.  Installing the Sourcesafe service pack that came with VB 6.0 fixed my problem.  Here is the Sourcesafe 6.0d service pack:

    http://www.microsoft.com/downloads/details.aspx?familyid=A8494EDB-2E89-4676-A16A-5C5477CB9713&displaylang=en

    Pablo G.

    Sunday, November 14, 2010 10:46 PM
  • Thanks for sharing the info, Pablo.

     


    Catherine Sea
    Version Control Software | Software Configuration Management Solution

    Tuesday, November 23, 2010 6:50 AM
  • hi, I got the same problem with you. And finally I resolved it like following:

    1. Open VS2005, then choose the menu:
    Tools->Options, then click "Souce Control"
    2. click drop-down box under text"Current souce control plug-in", use "None", rather then "Microsoft Visual Source Safe"
    Thanks, this just helped me.

    John Grove - DSS, Senior Software Engineer
    • Proposed as answer by Imbhu Tuesday, March 01, 2011 11:49 AM
    • Unproposed as answer by Imbhu Tuesday, March 01, 2011 11:49 AM
    • Proposed as answer by DigitalBones Wednesday, July 13, 2011 7:41 PM
    Tuesday, November 30, 2010 10:44 PM
  • Hi tjsailor

    really super am able to work with VS2005 with out issue. thank you so much buddy :)

    Tuesday, March 01, 2011 11:50 AM
  • I have the same problem. Everything was working fine up until today.

    Changing the source control to none will not fix this problem if you still want to use source control. It doesn't work for me at least. I am using visual studio 2008 professional edition.

    If I try to open a project that was previously under source control I get this error:

    • "There was a failure while initializing the Microsoft Visual SourceSafe source-control provider."

    Then after clicking ok I get this message:

    • "The project <name> appears to be under source control, but on this machine there isn't a source control provider installed."

     

    I tried MOSABUSAN 's    solution "update here http://support.microsoft.com/kb/943847. " and got this error message:

    • "The upgrade patch cannot be installed the the Windows installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch."

    I went to add/remove programs and attempted to uninstall the entry with SourceSafe in its name and got this error:

    • "An error occurred while trying to uninstall Microsoft Visual SourceSafe NetSetup. It may have already been uninstalled. Would you like to remove...."

    I clicked "NO" because I know ( or assume since it was working yesterday ) that it is really installed on my computer...

     

    So then I tried  Pabliski's solution and it completed w/o any problems....but it did not fix my problem:

     

    I then tried "sandeep patil "'s solution of registering the dll ( regsvr32 ssscc.dll ) but I could not find ssscc.dll on my computer. I found it on a network drive.... I did it from a command prompt and received this error message:

    • "The module "<path>\ssscc.dll" was loaded but the call to DllRegisterServer failed with error code 0x8000ffff."

    Ok so then I ran cmd as administrator and the service was successfully registered. But now I get this error(makes sense because I gave it a path from a network drive):

    • "Your source control provider <name> is using relative paths or paths that are not on local drives for locating its libraries."

     

     

    Final answer for my situation:

     

    When reinstalling the software I noticed that the default installation folder for VSS was C:\$Recycle.Bin and a few other directories.

    I emptied my recycle bin this morning and then I had problems.... funny huh?

    So my solution is to first try reinstalling VSS to a new directory that you create. This is what worked for me.

    • Proposed as answer by Soenhay Monday, June 20, 2011 8:06 PM
    Monday, June 20, 2011 8:04 PM
  • Hi,

    For the VSS problem.
    Here u check your installed path of VSS is correct or not. If your path is not correct then go to "start -> run ->"regsvr32  (modified path) \SSSCC.DLL"

    You have to register your dll using regsvr32. This will help.


    Tuesday, September 20, 2011 7:14 AM