none
An error occured when I installed the package WinCEPB60-101231-Product-Update-Rollup-Armv4I.msi RRS feed

  • Question

  • When I installed the package WinCEPB60-101231-Product-Update-Rollup-Armv4I.msi, an error occured with an alert " There is an problem with Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vender".

    And I check the event log. It said that "Product: WinCEPB60-101231-Product-Update-Rollup-Armv4I -- Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor.  Custom action SETREG2 script error -2146827859, Microsoft VBScript runtime error: ActiveX component can't create object: 'WSCript.Shell' Line 45, Column 1,  , (NULL), (NULL), (NULL), (NULL), , ."

    My OS is Windows XP SP3. I have already installed:

    1. Visual Studio 2005
    2. Visual Studio 2005 Service Pack 1
    3. Windows Embedded CE 6.0 Platform Builder Service Pack 1.msi
    4. Windows Embedded CE 6.0 R2
    5. Windows Embedded CE 6.0 R3

    Who can help me with this problem?

    Thank you.

    • Moved by Jesse Jiang Thursday, April 7, 2011 9:51 AM (From:Windows Mobile Development)
    Wednesday, April 6, 2011 7:09 AM

All replies

  •  

    Hi Jack,

     

    I think your issue should be raised in the Windows Embedded Compact Platform Development forum. I believe they will know more information of this issue than us, and I will move this one to that forum.

     

    Thanks for your understanding,

     

    Best regards,

    Jesse


    Jesse Jiang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, April 7, 2011 9:50 AM
  • Hi ,

     

    I have come face to face with the same problem , below please find the steps that I have followed.

    1-I have logged into the PC as an adiministrator .

    2-Just right click on the install package file and choose "resolve compatibility problem" or similar command and follow the instructions

    3-Package install will start and at some point , you may get a message saying that  some files to be updated  , are in use by "microsoft document explorer" ...

    4- I have stopped the "dexplore" service  by using task manager.

    5- The install  finished successfully.

     

    I hope this will resolve your case too.

     

    Regards

    murat

    Sunday, May 1, 2011 6:54 AM