none
BizTalk Adapter Deployment Issue RRS feed

  • Question

  • SDK Path: C:\Program Files\Microsoft BizTalk Server 2010\SDK\Samples\AdaptersDevelopment\File Adapter\

    - Assigned SNK to project

    - Build a project

    - Done GAC of below DLLs

        1. Microsoft.Samples.BizTalk.Adapter.Common.dll

        2. Microsoft.BizTalk.SDKSamples.Adapters.DotNetFile.Runtime.dll

        3. Microsoft.BizTalk.SDKSamples.Adapters.DotNetFile.Designtime.dll

    - Ran a StaticAdapterManagement.reg and DynamicAdapterManagement.reg

    - Added DesignTime.dll to BizTalk Admin Console.

    Created Adapter and Restrated HostInstances

    Getting below error

    Once click on OK, getting below screen

    • Changed type Ben Cline1Moderator Tuesday, August 20, 2013 6:51 PM asks a question about an issue
    Thursday, August 1, 2013 2:21 PM

Answers

  • The paths in the included reg files and the default install location for BizTalk server are different.

    You will see \Program Files\ in the reg file, but the default install folder is \Program Files (x86)\

    The reg file must match the assembly location.

    Note, for an actual production deployment, you should use the strong names for the Type values and remove the AssemblyPath values.

    "- Added DesignTime.dll to BizTalk Admin Console."

    What does this mean?  You don't add adapter assemblies to BizTalk Administrator.

    • Marked as answer by Pengzhen Song Monday, August 26, 2013 8:36 AM
    Thursday, August 1, 2013 2:55 PM

All replies

  • The paths in the included reg files and the default install location for BizTalk server are different.

    You will see \Program Files\ in the reg file, but the default install folder is \Program Files (x86)\

    The reg file must match the assembly location.

    Note, for an actual production deployment, you should use the strong names for the Type values and remove the AssemblyPath values.

    "- Added DesignTime.dll to BizTalk Admin Console."

    What does this mean?  You don't add adapter assemblies to BizTalk Administrator.

    • Marked as answer by Pengzhen Song Monday, August 26, 2013 8:36 AM
    Thursday, August 1, 2013 2:55 PM
  • Hi Hitesh,

    Please refer this link  which contains steps for deploying custom adapters.

    http://social.msdn.microsoft.com/Forums/en-US/587bae92-16f5-49ea-bc96-134356ff6134/failed-to-instantiate-adapter


    Srikanth Peddy. MCTS-BizTalk Server Please mark as answered . http://sharebiztalk.wordpress.com/


    Thursday, August 1, 2013 4:00 PM
  • After adding the required DLLs ,Did you restart the Admin console and try.Because it may be the problem with cache..

    Srikanth Peddy. MCTS-BizTalk Server Please mark as answered . http://sharebiztalk.wordpress.com/

    Thursday, August 1, 2013 4:04 PM
  • The screenshots are not showing well, but it looks like the properties are not visible. I think you probably need to install the reg keys into both the 32-bit and 64-bit registries. This is a common problem with custom adapter deployment.

    So you would do c:\Windows\regedit /I StaticAdapterManagement.reg but you also need to do c:\Windows\SysWow64\regedit /I StaticAdapterManagement.reg to get it into the 32-bit registry.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline


    Tuesday, August 20, 2013 6:31 PM
    Moderator
  • Check your file location, the reg file path and and the default install location for BizTalk server have to be same.

    http://www.athenainfotech.co.uk/free-biztalk-health-check

    Friday, August 30, 2013 6:05 AM