SSRS 2008 crashes when printing RRS feed

  • Question

  • My boss and I have tried printing a report from ssrs using ie9 and ie9 has crashed every time. I have tried printing a 6 page report and a 266 page report.


    Here are the crash details:

    Problem signature:
      Problem Event Name:    APPCRASH
      Application Name:    iexplore.exe
      Application Version:    9.0.8112.16421
      Application Timestamp:    4d76255d
      Fault Module Name:    rsclientprint.dll
      Fault Module Version:    2007.100.1600.22
      Fault Module Timestamp:    48753ed9
      Exception Code:    c0000005
      Exception Offset:    00017ab2
      OS Version:    6.1.7601.
      Locale ID:    1033
      Additional Information 1:    5924
      Additional Information 2:    5924ee88b0f6f8f98278cc0b0d3520e3
      Additional Information 3:    96ba
      Additional Information 4:    96baa22a84fe2a96f8985d8c8964a626

    Friday, July 8, 2011 5:01 PM

All replies

  • I am still having no luck printing. We are using different computers and different printers. IE9 locks up every time.
    Friday, July 8, 2011 8:56 PM
  • What happens if you export it as PDF and print that?
    Saturday, July 9, 2011 2:07 AM
  • When exporting to a PDF and printing it works. I guess this could be a work around for now, but it is slightly inconvenient.

    Monday, July 11, 2011 2:03 PM
  • Hi btull89,

    From the error message, this issue might be cause by the assembly(rsclientprint.dll) is corrupt or the RSClientPrint(it is a Microsoft ActiveX control) is blocked by Internet Explorer(IE). Please try to take the following steps to deal with this issue:
    1. Make sure the "Download signed ActiveX controls" setting is enabled or prompted in IE.
        a> Click "Tools" -> "Internet Options".
        b> Go to "Security" tab.
        c> Select appropriate zone(For example, if Report Server site is added to Trusted sites zone, please select
             Trusted sites zone).
        d> Click "Custom Level".
        e> Make sure the "Download signed ActiveX controls" settings is enabled or prompted.
    2. Delete the temporary.
        a> Click "Tools" -> "Internet Options".
        b> In "General" tab, click "Settings" in the "Browsing history" section.
        c> Click "View objects".
        d> In the new Windows Explorer window, delete all the rsclientprint ojbects.

    After that, please try to print a report on Report Manager. (For the first time, the RSClientPrint.cab will automatically to download and install on the local machine). If you get “Unable to load client print control” error message, please refer to the article to solve this issue:

    By the way, here is a similar thread about this issue, please see:

    If you have any more questions, please feel free to ask.

    Bin Long


    • Proposed as answer by Jeff Braeunig Wednesday, August 27, 2014 4:54 PM
    Tuesday, July 12, 2011 7:43 AM
  • Correct ..with following of above option  Problem will be resolve.

    Tuesday, July 12, 2011 10:15 AM
  • Thank you for your response Bin.

    For solution 1: the "Download signed ActiveX controls" settings was on prompted for all zones except for restricted.

    For solution 2: I deleted all the rsclientprint objects, and then I got “Unable to load client print control” with an option to install the printer control in a popup that the bottom of the window. I downloaded the printer control and now my browser freezes. I went to the link for the “Unable to load client print control” issue, but I no longer get that message box, and I have version 10.x and the solution only mentions 8.x and 9.x. 


    It does seem like that user was having the same problem.

    Tuesday, July 12, 2011 1:00 PM
  • Here is an interesting tidbit.

    When I have enable protected mode unchecked then the printing works. If I have it checked then the browser freezes. Bad thing is the system administrator seems to have enable protected mode checked by default for all of our users.

    Tuesday, July 12, 2011 1:04 PM