SharePoint workflows (2013) not running. RRS feed

  • Question

  • We all of a sudden had our SharePoint 2013 workflows stop running. We can't figure out if there was an update. The only thing that we did on the day this started happening is we enabled the Windows Desktop Experience feature. We have tried turning it back off and they still do not work. SharePoint 2010 workflows to run manually. We have re-installed the workflow manager as well as all associated services. Any help would be appreciated.



    Monday, September 16, 2019 10:21 PM

All replies

  • Try registering the workflow service with the below command.

    Register-SPWorkflowService -SPSite https://site_name -WorkflowHostUri -ScopeName SharePoint
    Thanks & Regards,

    sharath aluri

    Tuesday, September 17, 2019 12:36 AM
  • Hi Sharath, thanks for the reply, but we have already tried that. Any other suggestions?
    Tuesday, September 17, 2019 3:16 PM
  • Make Sure the workflow Services are running fine in the workflow Manager. Try running the below command and check the status.



    Thanks & Regards,


    sharath aluri

    Wednesday, September 18, 2019 12:09 AM
  • Hi Sharath, it appears to me that all is ok with the status. Do you see any services I may be missing or have any other suggestions?

    Thanks again for your help.

    ServiceName                                  ServiceStatus

    WorkflowServiceBackend                 Running

    WorkflowServiceFrontEnd                Running

    ServiceName                                  Status

    Service Bus Gateway                       Running

    Service Bus Message Broker             Running

    Service Bus Resource Prov...            Running

    Service Bus VSS                              Running

    FabricHostSvc                                 Running

    • Edited by DAB2629 Wednesday, September 18, 2019 3:57 PM
    Wednesday, September 18, 2019 3:54 PM
  • Nope that's it. try restarting the services and then give it a try.

    Thanks & Regards,

    sharath aluri

    Wednesday, September 18, 2019 4:07 PM
  • Hi,

    Any ULS logs showing errors?

    We had to go thru and do the app permissions for some workflows a few months ago. You might try this on one of the workflows.. 

     Just go thru steps in the section:  "Granting the App Permissions"

    After we did this, workflows were happy again.

    Another resource we used.



    • Edited by NiteWalker Thursday, October 10, 2019 6:20 PM
    Thursday, October 10, 2019 6:18 PM