locked
Nuget 2.12 in Xamarin Studio RRS feed

  • Question

  • User37589 posted

    Hello Guys,

    I am using latest Xamarin Studio and I cannot install Microsoft.Net.Http from nuget, because it requires 2.12 version of nuget. Xamarin Studio has version 2.8.7.

    Is there any way to update it?

    Tuesday, June 28, 2016 9:54 PM

Answers

  • User18049 posted

    Xamarin Studio 6.1 on the alpha channel includes NuGet v3 so you can try using that.

    Looking at the Microsoft.Net.Http NuGet package it has a min client of 2.8.1 not 2.12. I tried installing it in Xamarin Studio 6.0 and it installs without any errors. Xamarin Studio 6.0 supports NuGet 2.8.7.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Wednesday, June 29, 2016 9:51 AM

All replies

  • User18049 posted

    Xamarin Studio 6.1 on the alpha channel includes NuGet v3 so you can try using that.

    Looking at the Microsoft.Net.Http NuGet package it has a min client of 2.8.1 not 2.12. I tried installing it in Xamarin Studio 6.0 and it installs without any errors. Xamarin Studio 6.0 supports NuGet 2.8.7.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Wednesday, June 29, 2016 9:51 AM
  • User238869 posted

    I was having an issue with this as well. What I realized was that I was trying to install the package System.Net.Http instead of the Microsoft.Net.Http.

    System.Net.Http needs the 2.12 version of nuget Microsoft.Net.Http was good with 2.8.7

    JUST incase anybody was having the same issue

    Saturday, July 2, 2016 5:48 PM