locked
Windows Phone 8.1 MDM: Not able to fetch PhoneNumber via DeviceInstanceService CSP RRS feed

  • Question

  • Hi All,

    I have been trying to retrieve the phone number of Windows Phone 8.1 device using the DeviceInstanceService CSP.

    I am doing a GET on ./Vendor/MSFT/DeviceInstanceService/PhoneNumber and all I get back is Status as "200" and Data as null i.e <Data></Data>

    I have found same issue reported on below threads but no solution or workaround found hence posting again:

    https://social.msdn.microsoft.com/Forums/en-US/77067ab3-8825-4329-a48e-28b2cf34dd03/cant-retrieve-phonenumber-using-window-phone-81-mdm?forum=developingmdmsolutions

    https://social.msdn.microsoft.com/Forums/en-US/c896fd7e-2fe9-400a-b25b-a2b7663f32c5/windows-phone-81-mdm-syncml-not-able-to-fetch-phonenumber?forum=developingmdmsolutions

    Please let me know if any solution/workaround available for this issue. Thanks.

    Regards,

    Ganesh Shinde

    Tuesday, November 25, 2014 1:57 PM

Answers

  • Hi All,

    I am able to get Phone number via MDM. Below is response I got from device.

            <Status>
                <CmdID>16</CmdID>
                <MsgRef>1</MsgRef>
                <CmdRef>904-7</CmdRef>
                <Cmd>Get</Cmd>
                <Data>200</Data>
            </Status>
            <Results>
                <CmdID>17</CmdID>
                <MsgRef>1</MsgRef>
                <CmdRef>904-7</CmdRef>
                <Item>
                    <Source>
                        <LocURI>./Vendor/MSFT/DeviceInstanceService/Identity/Identity1/PhoneNumber</LocURI>
                    </Source>
                    <Data>**********</Data>
                </Item>
            </Results>

    Issue got resolved when I did factory reset of device and sim card was already added in device.

    Please note if Phone number is displayed on phone under Phone settings, then only I think we can fetch PhoneNumber via DeviceInstanceService CSP. Else it will return status 200 with empty Data tag.
    Goto Settings-> phone, then open SIM settings which is at the bottom
    If under phone setting, U can see My phone number then it will work.

    Worked for me on Lumia 630 DUAL sim phone.

    Cheers!!!!!

    Regards,
    Ganesh Shinde
    • Marked as answer by Ganesh14Shinde Friday, February 13, 2015 7:19 AM
    Friday, February 13, 2015 7:19 AM

All replies

  • Are the devices you are testing also dual-SIM phones?

    Please provide details regarding the device model, carrier, and version information for the devices you are testing.  (...from settings -> about -> more info)

    for example:

    ------------------
    Model: NOKIA Lumia 1520
    Carrier: AT&T
    OS version: 8.10.14203.306
    Firmware revision number: 02061.00074.14273.33019
    Hardware revision number: 4.1.0.0
    Radio software version: 201c110.00024.0001
    Chip SOC version: 8974
    ------------------


    Eric Fleck, Windows Store and Windows Phone Developer Support. If you would like to provide feedback or suggestions for future improvements to the Windows Phone SDK please go to http://wpdev.uservoice.com/ where you can post your suggestions and/or cast your votes for existing suggestions.

    Tuesday, November 25, 2014 8:48 PM
  • Hi Eric,

    Thanks for the reply.

    I am using Lumia 925 which is single sim phone

    Details:

    Model: NOKIA Lumia 925
    Carrier: BSNL Mobile
    OS version: 8.10.12393.890
    Firmware revision number: 3051.50009.1424.0003
    Hardware revision number: 0.5.0.1
    Radio software version: 3.2.04059.1
    Chip SOC version: 8960

    I have also tested this on dual sim phone Lumia 630. I have used LocURI as specified in protocol document for getting phone number in case its dual sim phone.

    Details:

    Model: NOKIA Lumia 630
    Carrier: BSNL Mobile
    OS version: 8.10.12397.895
    Firmware revision number: 01061.00066.14235.36002
    Hardware revision number: 3.0.4.0
    Radio software version: 20c9.00038.0001
    Chip SOC version:8626

    Its not working on both the phones.

    Regards,

    Ganesh Shinde

    Wednesday, November 26, 2014 6:11 AM
  • Hi Eric,

    I have also checked with different carrier: Airtel but its not working.

    Regards,

    Ganesh Shinde

    Wednesday, November 26, 2014 10:03 AM
  • Any Update on this issue?
    Wednesday, December 17, 2014 11:35 AM
  • No, no new information yet.


    Eric Fleck, Windows Store and Windows Phone Developer Support. If you would like to provide feedback or suggestions for future improvements to the Windows Phone SDK please go to http://wpdev.uservoice.com/ where you can post your suggestions and/or cast your votes for existing suggestions.

    Wednesday, December 17, 2014 8:25 PM
  • Hi All,

    I am able to get Phone number via MDM. Below is response I got from device.

            <Status>
                <CmdID>16</CmdID>
                <MsgRef>1</MsgRef>
                <CmdRef>904-7</CmdRef>
                <Cmd>Get</Cmd>
                <Data>200</Data>
            </Status>
            <Results>
                <CmdID>17</CmdID>
                <MsgRef>1</MsgRef>
                <CmdRef>904-7</CmdRef>
                <Item>
                    <Source>
                        <LocURI>./Vendor/MSFT/DeviceInstanceService/Identity/Identity1/PhoneNumber</LocURI>
                    </Source>
                    <Data>**********</Data>
                </Item>
            </Results>

    Issue got resolved when I did factory reset of device and sim card was already added in device.

    Please note if Phone number is displayed on phone under Phone settings, then only I think we can fetch PhoneNumber via DeviceInstanceService CSP. Else it will return status 200 with empty Data tag.
    Goto Settings-> phone, then open SIM settings which is at the bottom
    If under phone setting, U can see My phone number then it will work.

    Worked for me on Lumia 630 DUAL sim phone.

    Cheers!!!!!

    Regards,
    Ganesh Shinde
    • Marked as answer by Ganesh14Shinde Friday, February 13, 2015 7:19 AM
    Friday, February 13, 2015 7:19 AM