locked
publish infopath to sharepoint RRS feed

  • Question

  • hi everybody

    when I make to publish infopath to sharepoint display message error :

    the following url is not valid : http:// <name site >

    how I can solve it?
    Tuesday, November 3, 2009 7:26 AM

Answers

  • Hi Waheeba,

    You need to check permission in sharepoint (root site collection) and not in InfoPath, because when you provide url (Sharepoint root site collection) in InfoPath publishing wizard it tries to connect target server, if you don't have permission on your sharepoint root site collection then InfoPath will return you the error, not accurate enough though in most cases.


    Ashraf ul Islam
    Sharepoint Consultant
    Tuesday, November 3, 2009 12:36 PM
  • Go to the root site collection and click on People and Groups.  The permissions at the top-level are there.
    SharePoint Architect || My Blog
    Wednesday, November 4, 2009 5:57 AM

All replies

  • Hi,

    Can you try to open that URL from browser. May be you are giving wrong URL.
    Anuma Chinthapalli / http://www.GGKTech.com
    Tuesday, November 3, 2009 7:47 AM
  • Hi Anuma

    I am sure that the URL is correct

    Kindly help me
    Tuesday, November 3, 2009 7:56 AM
  • Hi Waheeba,
    • The first place to look at is, make sure you have got root site collection created on your target MOSS server ("/").
    • Make sure you have SSP created and configured.
    • If your site is not on default port, you may need to register your site in host file (normally available under WINDOWS\system32\drivers\etc  hosts. Edit file in notepad and add a line in the bottom in a format <YOUR SERVER IP>   <HOST-HEADER>, or you might need to have a look at dns to make sure your server is registered there for infopath to access your site.

    Ashraf ul Islam
    Sharepoint Consultant
    Tuesday, November 3, 2009 10:08 AM
  • Hi Ashraf Ul Islam

    I try what's you talk ,but It still problem




    Tuesday, November 3, 2009 11:30 AM
  • Hi Waheeba,

    Could you let us know how you have checked all the points i mentioned in my previous post, have a look at EvenViewer and check if there is any exception / error logged after you tried to publish infopath.

     
    Ashraf ul Islam
    Sharepoint Consultant
    Tuesday, November 3, 2009 11:43 AM
  • Hi Again Waheeba,

    Another question, do you (current user) have enough permission on the root site collection of target server ?

    Ashraf ul Islam
    Sharepoint Consultant
    Tuesday, November 3, 2009 11:53 AM
  • Make sure there should be Site Collection created at Root level for selected Web Application. This is the solution for this error.

    If you created Web Application e.g. 8888. Make sure you have created the Site at http://server:8888 otherwise it will give "Invalid Url" error even if Site is created at http://server:8888/sites/site & no site exist at http://server:8888 root level.
    Cheers, Ashwin B.
    Tuesday, November 3, 2009 12:12 PM
  • How I can known the permission of current user  in infopath ?
    Tuesday, November 3, 2009 12:27 PM
  • Hi Again Ashraf
    There aren't error display any error in the EventViewer
    Tuesday, November 3, 2009 12:28 PM
  • Hi Waheeba,

    You need to check permission in sharepoint (root site collection) and not in InfoPath, because when you provide url (Sharepoint root site collection) in InfoPath publishing wizard it tries to connect target server, if you don't have permission on your sharepoint root site collection then InfoPath will return you the error, not accurate enough though in most cases.


    Ashraf ul Islam
    Sharepoint Consultant
    Tuesday, November 3, 2009 12:36 PM
  • I'm sorry

    I'm not understand what do you mean ?

    please how I can check permission in sharepoint root site collection ?

    I'm exhausted from this problem
    Wednesday, November 4, 2009 5:33 AM
  • Go to the root site collection and click on People and Groups.  The permissions at the top-level are there.
    SharePoint Architect || My Blog
    Wednesday, November 4, 2009 5:57 AM
  • We got this issue when AJAX was configured for the SharePoint site. When we rolled-back the Web.config file, publishing started working again.

    At this stage we don't know the specific AJAX config setting which causes the error.
    Wednesday, December 9, 2009 3:53 AM