none
I am not able to test the MSDTC from my application to Database Server RRS feed

  • Question

  • Hi,

    Applicaiton server : win server 2016

    Database server : Linux ( Ubuntu)  on which SQL 2019 is installed 

    Hi , i  have open all the ports from my applicaiton server to DB server , but still i am not able to test my DTC connection , its saying failure message. Tried all the means but i am not able to fix, Can you please help me to fix . 

    I am able to ping the server both the direction wit  IP and Host name , i have also set the DTC com properties as per the defaults . 


    hemadri

    Saturday, May 23, 2020 10:44 AM

All replies

  • Good day hemadri,

    1. Before testing your application (which might have issue in the application side and just in the server configuration) please try to connec t the SQL Server using Azure Data Studio.

    2. Note: You mentioned that you opened the firewall in the app side, and what about the server side?


    signature   Ronen Ariely
     [Personal Site]    [Blog]    [Facebook]    [Linkedin]

    Saturday, May 23, 2020 1:05 PM
    Moderator
  • Hi, thanks for your reply . 

    Before me trying to connect through Azure Data Studio , i  tried testing DTC connection through the ping DTC ,  that will tell us is DTC working , before i confirm that from my applicaiton its not working . 

    But my DTC test itself is not working is my problem here. 

    in the server side as well the firewall is opened . 


    hemadri

    Saturday, May 23, 2020 3:08 PM
  • Please refer: https://docs.microsoft.com/en-us/archive/blogs/puneetgupta/troubleshooting-msdtc-issues-with-the-dtcping-tool

    ERROR MESSAGE 4 - There are no more endpoints from the endpoint mapper

    This error makes it appear that RPC is running out of DCOM Ports but you should not infer this error as a port exhaustion immediately. If you are able to run DTCPING.EXE on both the machines and during startup of the EXE, the tool doesn't complain of an out of port error, then this error is just a result of Firewall blocking the ports and the troubleshooting for this error should be exactly same as troubleshooting the "The RPC server is unavailable" error which is described above. Why am I saying that? Let's say that we are running out of DCOM ports (which can typically happen if you have specified a port range and the range is too small, something less than 30), then you should see an error the moment you start the DTCPING.EXE. Because that's when the DTCPing.exe will contact the End Point Mapper service (RpcSS) and ask for a dynamic port. If the DTCPing.exe starts up just fine, then it means that it got the right port allocated to it and hence there is no question of the Endpoint Mapper running out of DCOM ports.


    Please mark this reply as answer if it solved your issue or vote as helpful if it helped.
     [Blog]  [LinkedIn]  [twitter]

    Saturday, May 23, 2020 5:01 PM