locked
owc11.exe for office 20120 - 64 bit RRS feed

  • Question

  • I have developed application in visual studio 2005 and office 2003, which uses Microsoft Office Spreadsheet Component, AxMicrosoft.Office.Interop.Owc11.AxSpreadsheet
     
    I deployed my app on win 7 (32 bit) and office 2010 (32 bit). So to make it work I had to install office 2003 web components add on (owc11.exe) on the win 7 (32 bit) PC. So it worked very well.
     
    But now I deployed my app on win 7 (64 bit) and office 2010 (64 bit). I installed same owc11.exe on this machine but its not working ??
     
    What should be the solution to make it work ? How to make it compatible with office 2010 , 64 bit?
     
    Or any other solution ??

    h2007


    • Edited by h2007 Monday, October 21, 2013 6:37 AM
    Friday, October 18, 2013 4:45 AM

Answers

  • Try changing the platform from “Any CPU” to “x86”: http://www.tech-archive.net/Archive/Office/microsoft.public.office.developer.web.components/2007-07/msg00011.html

    • Marked as answer by h2007 Monday, October 21, 2013 1:12 PM
    Friday, October 18, 2013 6:51 AM

All replies

  • Try changing the platform from “Any CPU” to “x86”: http://www.tech-archive.net/Archive/Office/microsoft.public.office.developer.web.components/2007-07/msg00011.html

    • Marked as answer by h2007 Monday, October 21, 2013 1:12 PM
    Friday, October 18, 2013 6:51 AM
  • Hello,

    Whether Viorel's reply can help you?

    Which type of application is your application? ASP.NET web app?

    Or are you doing Office development?

    Please provide us detailed information.

    Thanks,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, October 18, 2013 9:46 AM
  • About my application,

    It is a windows application.

    Structure - Main.exe (visual studio solution)----> Accounts.dll

                                                                           Payroll.dll

                                                                           Fixed assets.dll

                                                                           setup project

    I have main.exe and accounts, payroll, FA are sub projects, have added as class library.

    So i use main.exe just to log in screen and menu for 3 sub project appears.

    i am using owc11 in accounts.dll

    So should i change the platform just for the accounts sub-projects or for all sub projects or only for solution or solution and projects (all) ?


    h2007

    Monday, October 21, 2013 6:53 AM
  • Hi,

    It seems that the issue is the OWC11.exe is not compatible with Office 2010 64 bit. Please see: http://social.msdn.microsoft.com/Forums/vstudio/en-US/92f0df87-b6a1-48ad-99ea-90ce79ef0a7e/using-owc11dll-spreadsheet-control-in-64-bit-office-vba?forum=officegeneral

    Since I am not very sure about the relationship between sub-projects, I suggest that you try to change the platform for the accounts sub-project first to check the result. If no help, change it for all projects in the solution.

    Thanks,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, October 21, 2013 8:21 AM
  • solved. I changed the platform from “Any CPU” to “x86” for entire solution (sub projects got changed automatically). It worked very well. Thank you Viorel.

    Method -

    Right click on solution -> Properties -> configuration Properties -> configuration manager -> Active Solution Platform -> change Any CPU to new and then select X86


    h2007


    • Edited by h2007 Tuesday, October 22, 2013 2:02 AM
    Monday, October 21, 2013 1:12 PM
  • Hi,

    I'm using OWC11.dll in my application which is run on 32 bit machine, In 64 Bit machine it's raising an error. The error seems like 

        Error 1:

     'AxMicrosoft.Office.Interop.Owc11.AxSpreadsheet' is not defined.  

    Error 2:

       The referenced component 'OWC11' could not be found. 

        Error 3:

    Could not resolve COM reference "0002e558-0000-0000-c000-000000000046" version 1.1. Object reference not set to an instance of an object.

    Eventhough I have changed the Configuration manager from 'Any CPU' to 'X86' Still it is not resolving. Any other solution to resolve this issue ? Any ideas greatly appreciated.

    By,

    Venkat

     

    Wednesday, December 18, 2013 11:43 AM