none
Migrating from .Net 3.5 to .Net 4.0 framework RRS feed

  • Question

  • Hello,

    I recently changed the targeted fromework of the Word 2007 Add-In from 3.5 to 4.0. After I mage the necessary changes and added the this.Factory.Createxxx() instead of the normal constructors of the ribbon objects, I tried to publish the project. The publish was sucessfull. When I tried running the setup.exe, an error appeared:

    Details:

    Name: 
    From: file:///C:/Users/Silviu/Desktop/OfficeIntegration/InnoreqWordPlugIn.vsto
    
    ************** Exception Text **************
    System.Deployment.Application.InvalidDeploymentException: Exception reading manifest from file:///C:/Users/Silviu/Desktop/OfficeIntegration/Application%20Files/InnoreqWordPlugIn_11_5_1_342/InnoreqWordPlugIn.dll.manifest: the manifest may not be valid or the file could not be opened. ---> System.Deployment.Application.InvalidDeploymentException: Parsing and DOM creation of the manifest resulted in error. Following parsing errors were noticed: 
    			-HRESULT: 	0x80070c81
    			 Start line: 	0
    			 Start column: 	0
    			 Host file: 	 ---> System.Runtime.InteropServices.COMException (0x80070C81): Exception from HRESULT: 0x80070C81
       at System.Deployment.Internal.Isolation.IsolationInterop.CreateCMSFromXml(Byte[] buffer, UInt32 bufferSize, IManifestParseErrorCallback Callback, Guid& riid)
       at System.Deployment.Application.Manifest.AssemblyManifest.LoadCMSFromStream(Stream stream)
       --- End of inner exception stack trace ---
       at System.Deployment.Application.Manifest.AssemblyManifest.LoadCMSFromStream(Stream stream)
       at System.Deployment.Application.Manifest.AssemblyManifest..ctor(FileStream fileStream)
       at System.Deployment.Application.ManifestReader.FromDocument(String localPath, ManifestType manifestType, Uri sourceUri)
       --- End of inner exception stack trace ---
       at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.GetManifests(TimeSpan timeout)
       at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InstallAddIn()

    I made a new project in the solution and published that. The publish for that one worked. I am sure that the cause of the problem is inside the migration process. Do I need to do something more after the migration that Clean the solution, rebuild, publish? Any idea would be of help.

    PS: I removed the old version from the machine before I tried to install the newly published version.


    Best regards,

    Silviu.


    http://www.rosoftlab.net/

    Wednesday, February 15, 2012 12:27 PM

Answers

All replies