locked
WFP - FwpsCloneStreamData0 STILL causes memory leak RRS feed

  • Question

  • Hi all,
    I know there was an open issue from Microsoft regarding this but as far as I can see it is still happening after all these years :)
    I am running Windows 8.1 Build 9600  and all I have to do to repro it is just run a stream edit sample which processes stream data OOB and open a few websites. All verifier flags are enabled for that driver. After a few minutes I unload it and let the browsers run and keep refreshing tab etc.. Soon enough all my RAM is gone and I cannot use the computer.

    The worst part about all of this is that the hotfix provided here I cannot install on my Windows 8.1 machine because I consistently get this error 0x080096002 - "The certificate for the signer of the message is invalid or not found" even though the digital signature is there. I have also tried installing Windows Identity Foundation to try to make it work, still get the same error.

    Are there any workarounds this, any new fixes, hotfixes etc.. ?

    I know Microsoft is pushing so much to use WFP but this makes it unusable, making your computer useless in less than an hour at least in my tests.

    Any input is appreciated, thanks.

    Gabriel




    B.Gabriel

    Thursday, June 11, 2015 4:06 PM