locked
Deployment Error

    Question

  • Hi,

    I have been developing a Windows Store App. After a while I took a break and had to reinstall the Developer License in Visual Studio.

    Now I am facing always the same error when trying to run the App: 

    DEP0600 The system cannot find the file specified.

    After some research I found that it may be the App Certificate which is broken but even new Projects I create don't work anymore. I work with Visual Studio Ultimate and tried it with Express too but always the same error.

    Does anyone have a clue how I can fix it or where the problem could be? I don't want to reinstall Windows 8 and all the Applications as I have found to be one solution.

    Thanks in advance.

    UPDATE:

    My Windows Installer doesn't work any more. I can't install, repair and uninstall programms. I might need to reinstall the windows installer but I can't find the one for Windows 8 yet nor I can fix the old one.

    Problem Solved!

    Read second answer.

    Sunday, April 28, 2013 8:35 PM

Answers

  • Hi Agnitio,

    Since your system has problems deeper than just the developer license you should address those issues first. The developer license issue likely is a symptom of the other problems, and fixing them will likely fix it. For help with the OS level issues please post on the Windows 8 forums on http://answers.microsoft.com .

    If you still have problems with the developer license after the OS is otherwise working please post again here.

    --Rob

    Tuesday, April 30, 2013 3:44 PM
    Owner
  • Hi Rob,

    Thanks for your and the other's fast response. I didn't post the issue on the answers site, since I found the solution by myself.

    I am pretty sure some others will come along the same issue as I've found the question with the same symptoms. So for future people to search for this solution I think even if it's in the wrong forum I will post the answere for completion.

    ANSWER:

    So it was indeed the MSI Installer. It is of course needed to deploy Windows 8 Apps and other applications. Somehow I was able to mess him up and followed the Method 1 in the following link:

    http://support.microsoft.com/kb/2642495

    If it then still doesn't work, repair your visual studio.

    -- agnitio


    • Marked as answer by agnitio Wednesday, May 1, 2013 8:00 PM
    • Edited by agnitio Friday, May 3, 2013 7:09 AM
    Wednesday, May 1, 2013 8:00 PM

All replies

  • Moving to the tools forum for better support.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Monday, April 29, 2013 4:01 PM
    Moderator
  • Hi,

    I'll try to involve more experts in this case.


    Aaron
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, April 30, 2013 8:39 AM
  • Hi Agnitio,

    Since your system has problems deeper than just the developer license you should address those issues first. The developer license issue likely is a symptom of the other problems, and fixing them will likely fix it. For help with the OS level issues please post on the Windows 8 forums on http://answers.microsoft.com .

    If you still have problems with the developer license after the OS is otherwise working please post again here.

    --Rob

    Tuesday, April 30, 2013 3:44 PM
    Owner
  • Hi Rob,

    Thanks for your and the other's fast response. I didn't post the issue on the answers site, since I found the solution by myself.

    I am pretty sure some others will come along the same issue as I've found the question with the same symptoms. So for future people to search for this solution I think even if it's in the wrong forum I will post the answere for completion.

    ANSWER:

    So it was indeed the MSI Installer. It is of course needed to deploy Windows 8 Apps and other applications. Somehow I was able to mess him up and followed the Method 1 in the following link:

    http://support.microsoft.com/kb/2642495

    If it then still doesn't work, repair your visual studio.

    -- agnitio


    • Marked as answer by agnitio Wednesday, May 1, 2013 8:00 PM
    • Edited by agnitio Friday, May 3, 2013 7:09 AM
    Wednesday, May 1, 2013 8:00 PM