none
Debugging has crushed

    Question

  • Hi;

    I am developing a web site with visual studio enterprise 2015.

    while i am debugging the program if i open game as "Metin2" debugging is stoping spontaneously.

    if the game open and i want to debug my site (when i click debuggin button on visual studio) it says:

    a fatal error has occurred and debugging needs to be terminated 0x80070005 error code 0x0

    How can i fix this problem.

    Best regards.

    Friday, February 10, 2017 12:26 PM

All replies

  • Hi Mert,

    Please try to update all the AssemblyInfo files.

    And go to AssemblyInfo.cs, Navigate to AssemblyVersion, modify it to "1.0.0.0" if it's not.

    Then click Build Solution and give it a try.

    Best regards,

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, February 13, 2017 3:14 AM
  • Hi Mert,

    Not sure if my suggestion above worked in your side.

    Is the game "Metin2" in the project or an outside application?

    If the game is not the project, I think you could create a new project and debug it in VS to have look.

    By doing above, it could help us to judge whether the project or VS IDE itself caused this issue.

    Thanks for you cooperation and let us help you out.

    Best regards,

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Thursday, February 16, 2017 10:22 AM
  • The game Metin2 isn't my project.It is game like Silkroad Online, Knight Online you may see the game on this link :

    https://us.metin2.gameforge.com/

    i have searched that what is  AssemblyInfo.cs then i found : It only gets created for Windows application.

    i actually observed that VS doesnt crush only when  want to debug my asp.net web site, i created a windows forms application and want to debug my app when game is open.VS freezed.

    My PC Features:

    16 GB RAM

    nVIDIA GTX 960M

    İ7-5700HQ 2.7 GHz

    x64

    Windows 10 Pro

    Sunday, February 19, 2017 8:56 AM
  • Hi Mert,

    The assembly file locates under Properties in Solution explorer :

    Please click to open it to check it as I mentioned above:

    And this issue is also perhaps caused by some add-ins, then I suggest you run VS in safe mode to give a check:

    devenv /safemode

    And please let me know if it work for you.

    Best regards,

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Sunday, February 19, 2017 11:42 AM
  • Hi Fletch,

    i realized that i have created my project as New Web Site > ASP.net Empty Web Site. (Framework 4.5.2 & c#)

    So there is no assembly file in my solution explorer.

    Then i created a new asp.net web form project, checked AssemblyVersion.it was "1.0.0.0".

    while debuggin mode is active i opened the game.Debuggin has stoped.Ouput:

    The program '[17872] iisexpress.exe: Program Trace' has exited with code 0 (0x0).
    The program '[17872] iisexpress.exe' has exited with code -55 (0xffffffc9).

    if i try to debug again it says:

    "Unable to start program c:/Program Files(x86)/IIS Express/iiexpress.exe

    Very harmful error"

    Maybe you want to know my VS has xamarin project types.but i just install these features to my VS. i did'nt even open once.

    Best regards.

    Sunday, February 19, 2017 5:42 PM
  • Hi Mert,

    Here are three suggestions for you to try:

    Go to project name -> Properties -> Web, change the project URL to another port number:

    Or

    Go to your solution folder, there is a hidden ".vs" folder with a "config" sub-folder, it has its own applicationhost.config file you need to either rename (or delete) that file and make sure the website(s) configured inside match the ASP.NET web app(s) in your solution that you are trying to debug.

    Or

    If you are using 64 bit machine:

    Go to Tools -> Options -> Projects and Solutions:

    Please let me know the result.

    Best regards,

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, February 20, 2017 3:25 AM