locked
Connecting to VM Issue with RDP RRS feed

  • Question

  • Hi all,

    So after uploading my two VHDs and creating two VMs, I can RDP into one of them but not the other one. See the content in the RDP files.

    I can connect to the second VM but not to the first one. RDP takes a while connecting to the first VM and then it fails.

    I am trying to figure out why one works and one does not, any thoughts? What should I check on the dashboard between the two. They both show Running.

    Thanks

    full address:s:MehrabNeww.cloudapp.net:3389
    username:s:Administrator

    full address:s:MehrabDNSLOVE.cloudapp.net:3389
    username:s:Administrator

    Tuesday, September 18, 2012 6:14 PM

Answers

  • Hi,

    If you are trying from your office location, i.e. using corporate network, there is a very high chance that the outgoing connection is getting blocked by your firewall.

    Click on the Virtual Machine that you have created and then go to the "Endpoints" page. Here there will be a default endpoint created for you to connect to your Virtual Machine. Check out its public port number and allow TCP traffic for this port in your firewall settings.

    Another option that we try out is that we edit the public port number of the endpoint to a value which is permitted through our corporate firewall, such as port 80/443.

    HTH

    • Proposed as answer by Pooja Singh Tuesday, September 18, 2012 7:04 AM
    • Marked as answer by Jiang Yun Tuesday, September 25, 2012 10:16 AM
    Tuesday, September 18, 2012 7:03 AM
  • Can you check if you've enabled the remote connection endpoint? By default it is enabled. But make sure you have not accidently deleted it. On the portal, select your virtual machine, and the click the endpoints tab. For more information, please post the question on http://social.msdn.microsoft.com/Forums/en-US/WAVirtualMachinesforWindows/threads
    • Marked as answer by Jiang Yun Tuesday, September 25, 2012 10:16 AM
    Thursday, September 20, 2012 7:38 AM

All replies

  • Hi all,

    So under my Virtual Machines, I have a VM with a status of running. At the bottom, I click on Connect and RDP opens up on my Windows 8 machine. However after trying to connect, it cannot connect and I get the RDP error saying that cannot connect to the remote computer for these 3 reasons ...

    Anyone know why I cannot connect to my VM?

    This is what is in my RDP file:

    full address:s:XXX.cloudapp.net:3389

    usernames:Administrator

    • Merged by Jiang Yun Thursday, September 20, 2012 7:56 AM
    Tuesday, September 18, 2012 12:19 AM
  • Hi,

    If you are trying from your office location, i.e. using corporate network, there is a very high chance that the outgoing connection is getting blocked by your firewall.

    Click on the Virtual Machine that you have created and then go to the "Endpoints" page. Here there will be a default endpoint created for you to connect to your Virtual Machine. Check out its public port number and allow TCP traffic for this port in your firewall settings.

    Another option that we try out is that we edit the public port number of the endpoint to a value which is permitted through our corporate firewall, such as port 80/443.

    HTH

    • Proposed as answer by Pooja Singh Tuesday, September 18, 2012 7:04 AM
    • Marked as answer by Jiang Yun Tuesday, September 25, 2012 10:16 AM
    Tuesday, September 18, 2012 7:03 AM
  • Can you check if you've enabled the remote connection endpoint? By default it is enabled. But make sure you have not accidently deleted it. On the portal, select your virtual machine, and the click the endpoints tab. For more information, please post the question on http://social.msdn.microsoft.com/Forums/en-US/WAVirtualMachinesforWindows/threads
    • Marked as answer by Jiang Yun Tuesday, September 25, 2012 10:16 AM
    Thursday, September 20, 2012 7:38 AM