none
"No provisioning handler" error, Exchange 2010, Powershell RRS feed

  • Question

  • Hello

    I'm doing a script in PowerShell for creating accounts.

    When creating the AD accounts I also want to create a mailbox for the user.

    When i try to enable the mailbox for the user i get the error "No provisiong handler is installed"

    The thing is that if i run the same line (enable-mailbox -identity x -alias -x etc) from Exchange Management Shell I don't get this error.

    I'm therefore wondering if the error is because of the same thing as in This Forum post , or could my error be because I'm only adding the Exchange with "add-pssnapin *exchange*" and is missing some line that Exchange Management Shell runs when it starts?

    //Alexander

    Thursday, February 24, 2011 6:55 PM

Answers

  • Was just searching this Topic but found that this thread hasn't been answered , We have resolved it by using below in our script instead of add-pssnapin..

    $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri http://ExchangeCAsSErvename/PowerShell/ -Authentication Kerberos
    import-pssession $session

    Just answering this old thread so that if someone reaches here find the answer.


    Sukhija Vikas http://msexchange.me

    Tuesday, April 14, 2015 3:00 AM

All replies

  • Was just searching this Topic but found that this thread hasn't been answered , We have resolved it by using below in our script instead of add-pssnapin..

    $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri http://ExchangeCAsSErvename/PowerShell/ -Authentication Kerberos
    import-pssession $session

    Just answering this old thread so that if someone reaches here find the answer.


    Sukhija Vikas http://msexchange.me

    Tuesday, April 14, 2015 3:00 AM
  • Hello

    Hmmm, I have same error anywhere.

    In Exchange Management Tool and in PS session.

    And I cant solve this problem... do you have any suggestion? 

    Thursday, July 23, 2015 12:48 PM