none
SQL Adapter RRS feed

  • Question

  • I have two select statements in my stored procedure, now when i generate a schema using sql adapter i am getting the schema for the first select statement only and not for the second. How to resolve this.
    Saturday, September 12, 2009 10:55 AM

All replies

  • Try moving both statements into a stored procedure and having the stored procedure be the source you generate the schema on. You may not be able to run a batch of statements from the port.

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Sunday, September 13, 2009 5:19 PM
    Moderator
  • Please read my question again, i have mentioned that i already have a Stored procedure with two select statements in it. Now the issue is that the schema that is getting generated is having fields specified in the first select statement only while for the second select the schema is not having anything.

    Monday, September 14, 2009 6:22 AM
  • Try wrapping the first select statement in a separate stored procedure.  Then call this new stored procedure inside your main sp in place of the first select statement.  If it works, please mark as an answer.
    Tuesday, September 15, 2009 7:12 PM
  • Use Join / Temp DB instead.
    Kerrey [BizTalk Consultant]
    Friday, September 18, 2009 7:42 PM
  • Which SQL adapter are you using ? Is it the SQLXML based adapter which shipped with BizTalk server 2006/R2 or is this the WCF based SQL Adapter shipped with BizTalk Adapter Pack 2.0 ?
    Abhinav
    Tuesday, September 22, 2009 11:31 AM