locked
Vista 64-bit LSP install problem -- permissions? RRS feed

  • Question

  •  

    I have a 64-bit LSP, for which I wrote a little faceless MFC application that installs it in the 64-bit catalog on Vista.  With the file in my Users\Documents folder, I was able to install the LSP using my program and test it successfully.  Then I gave the LSP DLL and the installation EXE to the person who builds our installer program (using InstallShield) and it doesn't work -- when the machine reboots after installation it either hangs before the login prompt or gives an "Access Denied" message when you try to log in.  Removing the LSP from the catalog solves the problem.  Since it's the same LSP file and the same method of installing it in the catalog as when it worked for me, it has to have something to do with either the file's location (we tried both C:\Windows and our program directory) or the permissions on the file.  Are there specific perrmissions needed to get a 64-bit LSP to run properly in 64-bit Vista?  (There's a 32-bit LSP that gets installed at the same time that works fine.)

     

    Thanks,

    Jeff Metzner

    Monday, January 26, 2009 11:04 PM

All replies

  • MSDN states that LSPs can only be installed into the system folders (on 64 bit that's Windows\system32, and 32bit is Windows\Syswow64).
    Wednesday, September 15, 2010 4:07 AM