locked
Beta store issues. Win Phone 7.5 device does not get the latest update. RRS feed

  • Question

  •      I have published a first version of my app 5 days ago to the beta store.

         Once it was published to the beta store, I received the link to the app, and I installed the app on my Samsung Focus WinPhone 7.5 to test it. Did the same on my HTC 8x. 

         Yesterday, I updated the app and submitted again.

        Today I got the link but on my Samsung Focus, it installs the previous version from 5 days ago, not the latest version.

         I tried this several times. I do not have this problem on the HTC 8x, it gets the latest version.

         Why is the Win7.5 device not getting the latest version? I did not change the target OS for the app or anything like that, it's actually still listed for Win Phone 7.5 and Win Phone 8

         Issue #2: I unpublished the app from the beta store. 

         But to my surprise, the link was still working, I could still install the app on both my Samsung Focus and HTC 8x. Samsung Focus still installs the old version of my app. Why is the app still available to the beta store since I unpublished it?

         Some background info:  My app is a 7.1 app developed with Visual Studio 2012 on Win 8 machine.

         The Samsung Focus has a different Microsoft account than the HTC 8x one.





    Thursday, February 7, 2013 11:59 AM

All replies

  • Hi, even in beta you must wait a day or two before your app update is fully replicated in the microsoft back end. It's not an instantaneous procedure, when I was doing beta testing few users waited a full 5 days (after certification, aka signing) before receiving an update notification.


    • Edited by DiogoCardoso Thursday, February 7, 2013 12:06 PM
    Thursday, February 7, 2013 12:05 PM
  •    But the link to the app is the same for both the Windows Phone 7.5 and Windows Phone 8 devices. 

       And both of them are in the same location.

       How could it be because of the replication issues?




    • Edited by silverbyte1 Thursday, February 7, 2013 12:09 PM
    Thursday, February 7, 2013 12:08 PM
  •    The fact that I cannot easily show to other people the app during development is ridiculous. 

    Thursday, February 7, 2013 12:58 PM
  • The submission is a whole process, you receive the notification before the app is actually available for download, that is the point, relieving your worries about a certification process.

    In beta that is practically the same, when they say that the app was successfully signed doesn't mean that you can download it right now, they need to put the xap on their servers and I'm almost sure that this process isn't done right way, it queues up xaps and periodically they send a batch of them to be available.

    Note that this process is a worldwide one, not a action->reaction effect, this kind of things take time.

    This also justifies your issue #2 (sorry forgot to answer that).


    Thursday, February 7, 2013 1:12 PM
  • I understand what you are saying that it takes time for the XAP file to udapte across servers.

    But in my case, there are two devices in the same geographical location which install the same application. 

    Isn't it the same XAP file for both the WindowsPhone 7.5 and Windows Phone 8?

    I am thinking about the fact that there's some JIT compilation done which might result in different XAP files for each device.

    That could be the only explanation why one device gets the latest version and the other one not.

    Thursday, February 7, 2013 1:17 PM
  • I had similar problems, and after wait for 1 week, I published the application again, and it worked the next day

    It seems to be a problem with server caches



    no where man
    http://www.nowhereman.eu

    Thursday, February 7, 2013 2:00 PM
  • Today I found another "issue", I had my software installed. I changed mobile language from spanish to english. Then Market talk me that I had an upgrade from my application. I installed, and it installed a old version!

    if before installed I change language back to spanish, the upgrades are there, but if I try to upgrade, it doesn't install anything !!

     



    no where man
    http://www.nowhereman.eu

    Tuesday, February 26, 2013 6:55 PM
  • As said here the apps are recompiled to WP8.

    Did your app get update since then?

    Tuesday, February 26, 2013 10:14 PM