none
Which NetWork version RRS feed

  • Question

  • Hi,

    When starting VS 2013 it says "See what's new in .NET Framework 4.5.1"

    but when I click Help, it  states Microsoft .NET Framework, Version 4.6.0155"

    For deploying I need to apply the correct redistributable, so my question is:

    - building my application do I need the Redistributable for V4.5.1 or for V6?

    Looking forward to the reply.

    GerritV2

    Monday, May 8, 2017 2:40 PM

Answers

  • Hi GerritV2,

    >>- building my application do I need the Redistributable for V4.5.1 or for V6?

    If the version of your application what you want to publish is .Net Framework 4.5.1, you just need to choose the 4.5.1 version and if your application is 4.6.0, of cause you need to choose the 4.6.0 version, means the version of the Prerequisites depends on the version of your application.

    By the way, just as we all know, the latest version is generally compatible with previous versions, so I think you can also choose the latest version in the Prerequisites.

    Best Regards,

    Stanly


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by GerritV2 Tuesday, May 16, 2017 8:11 AM
    Tuesday, May 16, 2017 6:26 AM

All replies

  • Hi GerritV2,

    Thank you for posting in MSDN forum.

    For the first scenario you mentioned, at the very beginning when the Visual Studio 2013 is just released, the latest Net Framework is 4.5.1, but  once highly compatible, in-place update version is released, It will add its documentation to the Help, to show you the new function.

    The highest .Net Framework version 4.6.2 can support on VS 2013.

    Please refer to:

    http://getdotnet.azurewebsites.net/target-dotnet-platforms.html#

    >>building my application do I need the Redistributable for V4.5.1 or for V6?

    To have a better understanding of your question, could you please express us more about the "Redistributable" ? do you mean the Visual C++ Redistributable packages? Actually the Redist and .Net Framework are two different things.  Do you want to develop a setup project, then add the responding .Net Framework into it?

    Or if I misunderstand your question, please feel free to tell me, I will correct and try to help you solve it.

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Tuesday, May 9, 2017 8:43 AM
    Moderator
  • Hi Lana,

    I'm a bit confused by your question. I "tried" to apply ClickOnce to make a setup, ChickOnce request which Prerequisites are required, so I set .NET Framework 4.5.1. Continuing the setup was made, and executing the setup on the same PC as where the application was developed, the application runs smoothly. But executing on an other PC it didn't execute, no sign of something missing, just "dead icon". So, I expected to miss the right Prerequisite, looked at Help and saw .NET Framework Version 4.5.6.01055. That stimulated my question.

    On the other machine I downloaded and executed several versions of .NET Framework (V4.5.1 - V4.5.6), but no response. So, I'm  missing something importent.

    By the way, doing the same procedure with a much simpler appl. (only a VS UI, no Intel DLL), that run fine on both machines.

    I hope you can shed some light on my ignorance.

    Looking forward to your reply.

    GerritV2

    Thursday, May 11, 2017 8:16 AM
  • Hi GerritV2,

    >>- building my application do I need the Redistributable for V4.5.1 or for V6?

    If the version of your application what you want to publish is .Net Framework 4.5.1, you just need to choose the 4.5.1 version and if your application is 4.6.0, of cause you need to choose the 4.6.0 version, means the version of the Prerequisites depends on the version of your application.

    By the way, just as we all know, the latest version is generally compatible with previous versions, so I think you can also choose the latest version in the Prerequisites.

    Best Regards,

    Stanly


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by GerritV2 Tuesday, May 16, 2017 8:11 AM
    Tuesday, May 16, 2017 6:26 AM