none
Cannot connect to reporting services from management studio express (SSMSE) RRS feed

  • Question

  •  

    hello there,

     

    --------------------------

    I posted this question in the "SQL Server Reporting Services" forum before (http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=3131624&SiteID=1&mode=1) and a moderator advised me to repost it in this forum.

    --------------------------

     

    I appreciate any help on the following issue:

     

    When I want to connect to a local reporting services server as shown in the "Reporting Services Tools" tutorial (http://msdn2.microsoft.com/en-au/library/aa337424.aspx), the SSMSE does not show the option "Reporting Services" in the "Server type" drop down list in the "Connect to server" dialog.

     

    The tutorial says "In the Server type list, select Reporting Services. If Reporting Services is not on the list, it is not installed."

     

    This must be wrong as the SSCM clearly shows an installed and running "SQL Server Reporting Service (...)".

     

    Also if i call the webinterface (http://localhost/reports/) a page loads that says "SQL Server Reporting Services Home" with some options. And here something is not correct too. The "contents" tab of the report manager says "There are no items in Home."

     

    I started to work on some basic tutorials using the sql server business development studio, and everything works fine. I can create reports, which derive data from the AdventureWorks db properly.

     

     

    Can anyone tell me the adequate steps to fix the SSMSE connection problem and the webinterface view problem?

     

     

    Here are some additional informations:

     

    I use WinXP SP2, which makes the IIS version 5.1

    SQL server is 2005 express with advanced features

    and i installed the management toolkit, and the AdventureWorks db.

     

     

    Installation history is as follows:

     

    .NET framework 2.0 + VS2005 professional edition was installed

    1. installed ss2005express+advanced features, on a named instance. worked fine. I did not install the SSMSE at this point, as i knew it is included in the toolkit too.

    2. configured the reporting services through the "reporting services configuration" tool. worked fine.

    3. installed the management tool kit. worked fine.

    4. installed the AdventureWorks db. installed, but was not attached automaticaly to the database engine.

    5. attached the AdventureWorks db to the database engine manually. worked fine, can be viewed and accessed properly.

     

     

    So there I am. I have no clue what went wrong.

     

     

    A last hint that makes me think is this: In the SSCM the sql server an the sql server reporting services have different instance ids (MSSQL.1 and MSSQL.2 respectively).

     

     

    Thanks in advance for your solutions and hints, that is - for your time :-)

    art

    Monday, April 7, 2008 5:35 PM