locked
Integration with Slack RRS feed

  • Question

  • Hi guys,

    I tried to integrate Slack with TFS by following the steps from official Visual Studio website, but when I entered the Webhook URL that I have created and run the TEST, I got the error from this picture:

    

    Maybe someone has had the similar problem ?

    Best regards,

    Sanja

    Friday, July 14, 2017 2:41 PM

All replies

  • Hi Sanja,

    Thank you for posting here.

    Please make sure your TFS server machine could connect to the Stack. It's seems that something wrong with your network settings.

    By the way, do you have a Visual Studio Team Service account, try to create a service hook in your VSTS using webhook url.

    Best regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Saturday, July 22, 2017 6:57 AM
    Moderator
  • Hi,

    Thank you for your response.

    Could you give me a little bit more detailed instructions on how to check if TFS server machine could connect with Slack ?

    Tnx and best regards,

    Sanja

    Monday, July 31, 2017 11:15 AM
  • Hi,

    We get this mistake when trying to send message from TFS to Slack:

    There was an error sending the request, so there was no response. 

    Error(s):

    An error occurred while sending the request.

        Unable to connect to the remote server

        No connection could be made because the target machine actively refused it 13.32.10.11:443

    Be sure there are no firewall rules blocking requests going out to the endpoint selected.

    Firewall is turned off. We think we should make TFS use proxy server.

    Does anybody know how to do it or has some other suggestion regarding this matter ?

    With best regards,

    Sanja

    Monday, August 7, 2017 7:58 AM