locked
MOSS 2007, set edit permissions on columns. RRS feed

  • Question

  • Hi!

    I'm using MOSS 2007. I have a list in datasheet view(all fields are single line of text type). I want to allow some users from AD to edit only some fields(in column A, for example), and deny them to edit any other fields(in columns B,C). They can see all columns, but can't edit some of them. I suppose the only way to do it is to create an event receiver(check what user is editing and show an error if restricted). But this method is very ugly, if the user changes I'll need to rewrite code of event receiver. Possible there is a better way to set permissions on columns.

    Tuesday, August 25, 2009 8:59 AM

Answers

  • Hi, Rockie

     

         This is a fields permission solution of Jianyi.  Unfortunately, he used hard code but not Resource file for this page.

     

       Just translation for your better understanding:

     

         Title: Field Permission setting(This is defined in aspx pages in layouts folder)

     

         ---------------------------------------------------------------------------------------------------------------

         Fields                                           View Permission                                                       Edit Permission

         ---------------------------------------------------------------------------------------------------------------

        Field1

                                                             All users [ ]                                                                         All users [ ]                                

                                                             Creator   [ ]                                                                        Creator   [ ]                                                             

                                                             Assign Permission To Users   [ ]                                 Assign Permission To Users   [ ]          

                                                             Assign Permission To Groups [ ]                                Assign Permission To Groups [ ]                                    

         ---------------------------------------------------------------------------------------------------------------

         ……

         Button[submit]

     

       I will also attempt to contact jianyi for the amendment language problems of the solution.

     

       Hope this translation can give you some help.

     

    Best Regards,

    -Aaron

    • Marked as answer by Rockie_ Tuesday, September 1, 2009 1:51 PM
    Thursday, August 27, 2009 11:11 AM

All replies

  • http://sppex.codeplex.com/
    Tuesday, August 25, 2009 9:11 AM
  • Hi lude8880!

    Thanks for Your reply. I downloaded CodeArt_PermissionEx.wsp, and added this solution by wsp_install.cmd file:


    @SET STSADM="c:\program files\common files\microsoft shared\web server extensions\12\bin\STSADM"  
    %STSADM% -o deletesolution -name CodeArt_PermissionEx.wsp  -override
    %STSADM% -o addsolution -filename CodeArt_PermissionEx.wsp
    pause

    But I don' see any added abilities, what does this addition make? I also don't see this feature in 
    Root Site > Site Settings > Site Features 

    Can You tell me how to deploy this feature correctly?

    Ok! Now I've deployed it from Central Administration>Operations>Solution Management.
    Using 
    stsadm -o displaysolution -name CodeArt_PermissionEx.wsp 
    command I can see that solution deploy status is "TRUE", but where can I see how it's work? It's bad that there is no documentation about this feature :(
    • Edited by Rockie_ Tuesday, August 25, 2009 1:45 PM
    Tuesday, August 25, 2009 1:14 PM
  • Did you deploy the solution using Central Administration?  Open Central Administration > Operations > Solution Management, click on the solution and deploy to relevant web applications or if it doesn't contain any web application scoped resources it will be deployed globally.

    Hope this helps

    Dave
    My SharePoint Blog - http://www.davehunter.co.uk/blog
    Tuesday, August 25, 2009 1:44 PM
  • Yes, Dave, I deployed it(I edited my last post):

    Ok! Now I've deployed it from Central Administration>Operations>Solution Management.
    Using 
    stsadm -o displaysolution -name CodeArt_PermissionEx.wsp 
    command I can see that solution deploy status is "TRUE", but where can I see how it's work? It's bad that there is no documentation about this feature :(
    Tuesday, August 25, 2009 1:54 PM
  • I assume you used

    stsadm -o deploysolution -name CodeArt_PermissionEx.wsp

    did you use the -immediate parameter?  Also did you run stsadm -o execadmsvcjobs?  Can you confirm the the solution is deployed?


    My SharePoint Blog - http://www.davehunter.co.uk/blog
    Tuesday, August 25, 2009 4:13 PM
  • >>did you use the -immediate parameter?  Also did you run stsadm -o execadmsvcjobs?  Can you confirm the the solution is deployed?
    Dave Hunter, no, I used -allowgacdeployment and yes, sulution was succesfully deployed. I used:

    %STSADM% -o deploysolution -name CodeArt_PermissionEx -allowgacdeployment -url http://spsite/spweb -local

    Thank You all for Your replies!

    I forgot to activate feature in Site Collection Features. Now "Field Permissions" setting appeared in List Settings Menu. Now it would be perfect, If I understand something :))





    lude8880, I saw You on chinese forum, You are one of the developers of this tool? Can You translate please this labels in english or link me to english instruction? :) I'm not so strong in chinese and I'm making experiments with users and these checkboxes :)

    Wednesday, August 26, 2009 9:58 AM
  • Hi, Rockie

     

         This is a fields permission solution of Jianyi.  Unfortunately, he used hard code but not Resource file for this page.

     

       Just translation for your better understanding:

     

         Title: Field Permission setting(This is defined in aspx pages in layouts folder)

     

         ---------------------------------------------------------------------------------------------------------------

         Fields                                           View Permission                                                       Edit Permission

         ---------------------------------------------------------------------------------------------------------------

        Field1

                                                             All users [ ]                                                                         All users [ ]                                

                                                             Creator   [ ]                                                                        Creator   [ ]                                                             

                                                             Assign Permission To Users   [ ]                                 Assign Permission To Users   [ ]          

                                                             Assign Permission To Groups [ ]                                Assign Permission To Groups [ ]                                    

         ---------------------------------------------------------------------------------------------------------------

         ……

         Button[submit]

     

       I will also attempt to contact jianyi for the amendment language problems of the solution.

     

       Hope this translation can give you some help.

     

    Best Regards,

    -Aaron

    • Marked as answer by Rockie_ Tuesday, September 1, 2009 1:51 PM
    Thursday, August 27, 2009 11:11 AM
  • hi rockie,
    we didin't expect such broad effect of this small projects, we will add the multilingual part asap.
    regards
    Andree Yang
    Monday, August 31, 2009 2:49 AM
  • Thank You very much for Your replies!

    lude8880, Aaron Han, ok, now I understand how it works!

    As I experiment, it does not deny to change items in Datasheet View :( But if it is not critical, I think this feature could be very useful.

    Tuesday, September 1, 2009 1:51 PM