none
On Connecting to SQL Azure from SSMS RRS feed

  • Question

  • Has anything changed recently after the SU1 update regarding connecting from SSMS?


    *    I did not get the 'ansi_null' error window.

    *    When I bypass the 'Connect to Server' window, and try a New Query I can see the New Query Window with correct information regarding the SQL Azure Server but the object browser is not displayed

    *   Too many connection time-out errors

    *   Any restriciton on the Firewall rule name? I gues there is.

    I am connecting from SSMS installed while installing SQL Server 2008 R2 Nov-CTP.


    mysorian
    Sunday, February 21, 2010 10:46 PM

Answers

  • >>When I bypass the 'Connect to Server' window, and try a New Query [which brings up the connect to server etc]  I can see the New Query Window with correct information regarding the SQL Azure Server but the object browser is not displayed. Just the query window.

    This is the desired behavior, because the connection is only valid for this particular query. To view the object browser, you must connect to Object Explorer, either through the first screen when you start SSMS, or manually click "File" => "Connect Object Explorer". Does this work for you?
    Lante, shanaolanxing This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, February 23, 2010 2:07 AM

All replies


  • I am connecting from SSMS installed while installing SQL Server 2008 R2 Nov-CTP.

    Do you mean at the time of writing this post, you're trying to connect from SSMS R1? This is not a supported scenario.

    Are you able to connect from SSMS R2 now? It should work fine.
    Lante, shanaolanxing This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, February 22, 2010 1:53 AM
  • Hi, Hayaram,
           
              You said: " *    When I bypass the 'Connect to Server' window, and try a New Query I can see the New Query Window with correct information regarding the SQL Azure Server but the object browser is not displayed"
            
            My SSMS worked well after SU1 update. But I have encountered similar problem before. Have you updated your SSMS recently? If the object browser can not be displayed, it might due to SSMS was not installed correctly. Can you please try to uninstall SSMS, and reinstall SQL Server 2008 R2 Nov-CTP on your machine? Before reinstalling SSMS, please make sure no SQL Service is running on your machine. 

     
    Thank you

    Gary
    Monday, February 22, 2010 3:11 AM
  • I never had SSMS R1. No, I am not connecting from R1. I am connecting from SSMS R2. This worked as it should during December 2009. I saw this behaviour(the follwoing observations) recently in the new SQL Azure server after the SU1 update.

    I repeat the previous post with additonal explanation:

    *    I did not get the 'ansi_null' error window, but I got the window dialog regarding not having configured Firewalls. This was a wrong message as I tried to connect only after setting up the firewall. I have been using SQL Azure for quite a few months.

    *    When I bypass the 'Connect to Server' window, and try a New Query [which brings up the connect to server etc]  I can see the New Query Window with correct information regarding the SQL Azure Server but the object browser is not displayed. Just the query window.

    * I connect again using a new connection, and this time I am able to see the object browser and the databases (master and another I created). My complaint is that the process must be invariable from user to user. I think this is erratic.

    *   Too many connection time-out errors

    * I still can connect to my CTP Server and access the databases.

    mysorian
    Monday, February 22, 2010 4:18 AM
  • If you're using SSMS R2, it should work fine. The 'ansi_null' error only occurs in in SSMS R1. So it is expected not to show here.

    Regarding the firewall issue, can you tell me more detais? What's the error message? Have you configured the local computer to open port 1433, as well as added a rule on the portal? You need to do both steps for SSMS to work.
    Lante, shanaolanxing This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, February 22, 2010 4:51 AM
  • I think (but I am not absolutely sure) that the firewall name cannot be the same as the local hosts name.

    >>When I bypass the 'Connect to Server' window, and try a New Query [which brings up the connect to server etc]  I can see the New Query Window with correct information regarding the SQL Azure Server but the object browser is not displayed. Just the query window.


    Why did this happen?
    mysorian
    Monday, February 22, 2010 3:38 PM
  • >>When I bypass the 'Connect to Server' window, and try a New Query [which brings up the connect to server etc]  I can see the New Query Window with correct information regarding the SQL Azure Server but the object browser is not displayed. Just the query window.

    This is the desired behavior, because the connection is only valid for this particular query. To view the object browser, you must connect to Object Explorer, either through the first screen when you start SSMS, or manually click "File" => "Connect Object Explorer". Does this work for you?
    Lante, shanaolanxing This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, February 23, 2010 2:07 AM
  • I can't view Object Explorer using either method. I get the error "Cannot connect to [server name].... Invalid object name 'sys.configurations'." I suspect that Object Explorer simply isn't available when connecting to SQL Azure via SSMS -- but does anyone have the "official" answer to this?
    Friday, March 5, 2010 6:49 PM
  • That's the error you're see if you're attempting to connect to SQL Azure with a pre R2 version of SSMS 2k8. If you use the R2 version, you should be able to connect normally.

    I documented my success doing this just yesterday at: http://bstineman.spaces.live.com/blog/cns!61AEA8168D26EA6B!1169.entry

    The article includes a link to the 32-bit version of SSMS I used in my testing.
    Friday, March 5, 2010 7:57 PM
    Moderator
  • Thanks! I'm running Windows 7 x64. Is there a 64-bit SSMS R2 and would you happen to have a link to it?
    Friday, March 5, 2010 10:30 PM
  • Nevermind. I found SQL 2008 R2 SSMS x64 on the MSDN download site. Everything is working fine now. Thanks again for your help.
    Saturday, March 6, 2010 12:17 AM