locked
Please help enable-migrations RRS feed

  • Question

  • User1266581083 posted

    Hello.

    After following this tutorial:

    http://dev.mysql.com/doc/connector-net/en/connector-net-entityframework60.html

    I have tried putting in my Nuget Console: "enable-migtation"

    and i am getting an error:

    PM> enable-migrations
    Checking if the context targets an existing database...
    System.TypeInitializationException: The type initializer for 'System.Data.Entity.Migrations.DbMigrationsConfiguration`1' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.Data.Entity.Internal.AppConfig' threw an exception. ---> System.Configuration.ConfigurationErrorsException: Configuration system failed to initialize ---> System.Configuration.ConfigurationErrorsException: Unrecognized configuration section entityFramework. (c:\users\tzahi\documents\visual studio 2013\Projects\Movies2\Movies2\tmp75A2.tmp line 7)
       at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
       at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
       at System.Configuration.BaseConfigurationRecord.ThrowIfInitErrors()
       at System.Configuration.ClientConfigurationSystem.EnsureInit(String configKey)
       --- End of inner exception stack trace ---
       at System.Configuration.ClientConfigurationSystem.EnsureInit(String configKey)
       at System.Configuration.ClientConfigurationSystem.PrepareClientConfigSystem(String sectionName)
       at System.Configuration.ClientConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection(String sectionName)
       at System.Configuration.ConfigurationManager.GetSection(String sectionName)
       at System.Configuration.ConfigurationManager.get_ConnectionStrings()
       at System.Data.Entity.Internal.AppConfig..ctor()
       at System.Data.Entity.Internal.AppConfig..cctor()
       --- End of inner exception stack trace ---
       at System.Data.Entity.Infrastructure.DependencyResolution.DbConfigurationManager.EnsureLoadedForAssembly(Assembly assemblyHint, Type contextTypeHint)
       at System.Data.Entity.Infrastructure.DependencyResolution.DbConfigurationManager.EnsureLoadedForContext(Type contextType)
       at System.Data.Entity.Migrations.DbMigrationsConfiguration`1..cctor()
       --- End of inner exception stack trace ---
       at System.Data.Entity.Migrations.DbMigrationsConfiguration`1..ctor()
       at Movies2.Migrations.Configuration..ctor() in c:\Users\Tzahi\Documents\Visual Studio 2013\Projects\Movies2\Movies2\Migrations\Configuration.cs:line 10
    --- End of stack trace from previous location where exception was thrown ---
       at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
       at System.Data.Entity.Migrations.Utilities.MigrationsConfigurationFinder.FindMigrationsConfiguration(Type contextType, String configurationTypeName, Func`2 noType, Func`3 multipleTypes, Func`3 noTypeWithName, Func`3 multipleTypesWithName)
       at System.Data.Entity.Migrations.Design.ToolingFacade.BaseRunner.FindConfiguration()
       at System.Data.Entity.Migrations.Design.ToolingFacade.ScaffoldRunner.Run()
       at System.AppDomain.DoCallBack(CrossAppDomainDelegate callBackDelegate)
       at System.AppDomain.DoCallBack(CrossAppDomainDelegate callBackDelegate)
       at System.Data.Entity.Migrations.Design.ToolingFacade.Run(BaseRunner runner)
       at System.Data.Entity.Migrations.Design.ToolingFacade.ScaffoldInitialCreate(String language, String rootNamespace)
       at System.Data.Entity.Migrations.EnableMigrationsCommand.<>c__DisplayClass2.<.ctor>b__0()
       at System.Data.Entity.Migrations.MigrationsDomainCommand.Execute(Action command)
    The type initializer for 'System.Data.Entity.Migrations.DbMigrationsConfiguration`1' threw an exception.

    Can someone help me?

    Thursday, July 2, 2015 2:51 PM

Answers

  • User37182867 posted

    Its helpful to post how it was solved and mark the answer. This way if someone else comes across this post they will know how you solved your problem.

    My guess is that you had the wrong project selected in your Package Manager Console.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, July 2, 2015 4:28 PM

All replies

  • User1266581083 posted

    This was solved.

    Thursday, July 2, 2015 3:27 PM
  • User37182867 posted

    Its helpful to post how it was solved and mark the answer. This way if someone else comes across this post they will know how you solved your problem.

    My guess is that you had the wrong project selected in your Package Manager Console.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, July 2, 2015 4:28 PM