none
User Controls suddenly stopped compiling RRS feed

  • Question

  • Hi,

    I have a number of User Controls in my project, which have suddenly stopped compiling after no problems for a couple of years.

    The controls are not in a seperate DLL.

    I ran debug OK this morning, then later tried again and got a list of errors like  'Name "combobox" is not declared' for all my User Controls.

    I closed the project and restarted. Then closed VS2008 completely and restarted, and finally shut down the computer and restarted everything.

    Nothing changed.

    I've checked that AutoToolBoxPopulate is set to True.

    I'm completely at a loss and unable to work.

    Cheers

    Thursday, May 19, 2011 11:20 PM

All replies

  • This problem is sending me nuts.

    I guess I should have the user controls in a DLL, but even that isn't altogether explained in any of the documentation I can find.

    Supossedly there is a Class Library template in the Template file, but I can't find it, and I am using VS2008 Pro.

    At present my user controls are simply in my Project folder, and as I said previously, have been happy there for a couple of years. Now they disappear from time to time, and as a number of my forms rely on them, I can't compile or do a debug.

    Any ideas would be welcome.

    Thanks

     

    Absolutely wierd.!!! Done nothing different and suddenly the User Controls reappear in my toolbox, however a number have vanished from a couple of forms.

    This has happened a few times lately and there is no obvious reason, unless it's because I've been leaving the solution open overnight.

     

     


    Friday, May 27, 2011 1:44 AM