locked
visual studio extensions installation RRS feed

  • Question

  • hello,

    i developped an extension using visual studio 2015. the extension needs to be working for both vs 2013 and 2015. the extension works fine on machines in which vs 2015( and got installed on both vs 2013 and 2015) is installed but not on other machines. i got the exception saying that could not find any suitable products to apply the extension.

    any advise ?

    Sunday, May 14, 2017 10:17 AM

All replies

  • Ensure that source.extension.vsixmanifest contains:

      <Installation InstalledByMsi="false">
          <InstallationTarget Id="Microsoft.VisualStudio.Pro" Version="[12.0,14.0]" />
       </Installation>
     

    That targets Visual Studio Professional / Community or higher for VS 2013 (12.0) and VS 2015 (14.0).

    Ensure also that you are not using references that are 14.0, only 12.0 or lower.


    My portal and blog about VSX: http://www.visualstudioextensibility.com; Twitter: https://twitter.com/VSExtensibility; MZ-Tools productivity extension for Visual Studio: https://www.mztools.com

    Sunday, May 14, 2017 6:04 PM