Reporting Services dll file


  • Hello,

    I am having an issue on my system regarding printing from the print icon on our report webpage.  It keeps giving me an error of Unable to load client print control.  I have read dozens of articles after googling this issue and have tried all the recommendations.  Basically, the error is a permissions issue to load the rsclientprint.dll file.  I logged into my admin account and registered the dll file and the print icon works under my admin account.  However, when I log into my regular user account, I get the error.  I have searched for an answer and have not come up with one.  I have unregistered the dll file and started over again, with re-registering the file.  I have even gotten admin permissions put on my regular user account and I still get the same error.  I am getting pretty frustrated as it works on other users systems, they are not having the same problem. 

    Has anybody else had this issue and/or there any other recommendations to try?  I am hopeful someone out here in SQL land might have an answer.

    Thanks for any help.

    Tuesday, July 02, 2013 1:24 PM


  • Hi KeithTexas,

    Try to grant “Read & execute” or “Full control” permission to the non-administrator user account on the following folder:
    C:\Windows\Downloaded Program Files

    Besides, please ensure the version of the current SSRS instance is the same as that of the SSRS instance on the other computer that don’t has this problem. You can get the build information from the Reporting Services Configuration Manager or by browsing the report server web service URL.

    Moreover, you can also try to disable the UAC feature which may cause permission issues.


    Mike Yin
    TechNet Community Support

    Thursday, July 04, 2013 8:00 AM