locked
The current custom error settings for this application prevent the details of the application error from being viewed RRS feed

  • Question

  • Hallo. 

    Ive got the following error on my developer sharepoint installation:

    "An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed." This standard page is shown to me when some exception happens on one of my application pages. (_layouts)

    Ive modified all web.config files I could find under /14 folder and under the root of my web app. And set customSettings mode=Off. In any place I found this tag including the webapp root and _layouts root.

    Still getting this error.

    Could u advice me anything?

    Thank u.

    Monday, December 3, 2012 2:07 PM

Answers

  • thank u for answers, actually the problem was about 

    <system.web>
    <deployment retail="true"/>

    ....

    </system.web>

    in the web.config. this setting enforces customErrors to be "On".

    And this is fun, because I need this setting to deal with other error, when App_GlobalResource dll "is already loaded to other  domain"...

    • Marked as answer by VlH Monday, December 10, 2012 4:11 PM
    Monday, December 10, 2012 4:03 PM

All replies

  • Hi VIH,

    As the page shows this message is an application, to show the error message, you need to modify the web.config file under layouts folder, the file is located at: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LAYOUTS.

    Open the web.config file,
    Find: <customErrors mode=”on”/>
    Replace with:<customErrors mode=”Off”/>

    Thanks,


    Qiao Wei
    TechNet Community Support

    • Proposed as answer by Hardik Bhilota Thursday, October 29, 2015 3:33 PM
    Friday, December 7, 2012 7:06 AM
  • as I said in my starting post, I have already modified this setting in every config file under /14 folder, including the "_layouts" one. It does not help.

    Sunday, December 9, 2012 2:33 PM
  • Have a look at this link this would solve your issue: 

    http://community.dynamics.com/product/crm/crmtechnical/b/marcellotonarelli/archive/2011/03/03/sharepoint-web-config-how-to-show-full-errors.aspx

    Sunday, December 9, 2012 3:09 PM
  • thank u for answers, actually the problem was about 

    <system.web>
    <deployment retail="true"/>

    ....

    </system.web>

    in the web.config. this setting enforces customErrors to be "On".

    And this is fun, because I need this setting to deal with other error, when App_GlobalResource dll "is already loaded to other  domain"...

    • Marked as answer by VlH Monday, December 10, 2012 4:11 PM
    Monday, December 10, 2012 4:03 PM