locked
Installation of MCMS RRS feed

  • Question

  • Hi,

    When i tried to install Microsoft Content Management Server it gives the message above!

    I've installed J# .NET Redistributable Package Version 2.0 but it says that needs 3.0 i can't find the 3.0 in the download area.

    Wich package sould i install in order to satisfy this requisite?

    Thanks in advance, Bruno Franco.

     

    Prerequisites

    WARNING!

    You have chosen to perform a complete installation; however, the following component(s) cannot be installed due to dependencies on applications that are not installed on this computer:

    • - Need Microsoft Visual Studio.NET 2002 (required by Developer Tools for Visual Studio.NET 2002)
    • - Need Microsoft Visual J# .NET Redistributable Package Version 3.0 (required by Site Manager and Site Stager)

    Microsoft Content Management Server SP1a Components

    Friday, February 2, 2007 3:03 PM

Answers

  • Hi -

    I just had this problem too and figured out the resolution! The MCMS installation wants to find the J# package for the most recent .NEt framework you have installed. I had 3.0 installed, which you must too, so even thought J# 3.0 doesn't exist, MCMS was looking for it. Just uninstall 3.0, do your MCMS installation, and then re-install 3.0 later. That should fix the problem!

    Good luck,

    Jen

    Monday, February 5, 2007 2:02 PM
  • Hi Jen,

    Thanks for the reply.

    It worked, Bruno Franco.

    Monday, February 5, 2007 4:40 PM

All replies

  • Hi -

    I just had this problem too and figured out the resolution! The MCMS installation wants to find the J# package for the most recent .NEt framework you have installed. I had 3.0 installed, which you must too, so even thought J# 3.0 doesn't exist, MCMS was looking for it. Just uninstall 3.0, do your MCMS installation, and then re-install 3.0 later. That should fix the problem!

    Good luck,

    Jen

    Monday, February 5, 2007 2:02 PM
  • Hi Jen,

    Thanks for the reply.

    It worked, Bruno Franco.

    Monday, February 5, 2007 4:40 PM
  •  

    Jennifer, you rock.

     

    Cheers

    Monday, October 1, 2007 3:58 PM
  •  

    I found a much easier way than to uninstall Microsoft .NET Framework 3.0, which was good for me because I have other applications which depend on 3.0 (Expression Blend, etc.)

     

    This is a RegEdit thing, so the usual Warning About Tampering With The Registry apply/

     

    In RegEdit, go to this key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\

     

    Rename the subkey v3.0 to something else -- I used XXXv3.0XXX.

     

    Now start the MS CMS install. Site Manager should now be enabled.

     

    Be sure to re-rename the reg key back to its original value when you're done.

     

    ->Alan

    Monday, January 21, 2008 7:44 AM
  •  

    This worked! Thanks.
    Friday, February 29, 2008 9:30 AM
  • It worked for me. Thanks.

     

    Friday, March 28, 2008 12:51 PM
  • thank you, the reg edit worked perfectly:)

    /Rasmus
    Tuesday, May 19, 2009 8:09 AM
  • Excellent. The registry fix worked for me and is the way forward!
    Thanks
    Monday, November 2, 2009 12:04 PM
  • A more elegant way is found thanks to Gyorgy. Basically creating a dummy file at C:\WINDOWS\Microsoft.NET\Framework\v3.0\vjslib.dll. No need to mess with registry.

    Details here:
    http://blogs.msdn.com/gyorgyh/archive/2009/01/21/mcms-2002-and-asp-net-framework-3-0.aspx

    • Proposed as answer by rafakbr Friday, January 15, 2010 11:19 AM
    Friday, January 8, 2010 6:53 PM
  • A more elegant way is found thanks to Gyorgy. Basically creating a dummy file at C:\WINDOWS\Microsoft.NET\Framework\v3.0\vjslib.dll. No need to mess with registry.

    Details here:
    http://blogs.msdn.com/gyorgyh/archive/2009/01/21/mcms-2002-and-asp-net-framework-3-0.aspx


    This worked flawlessly!  Who would know...  genius idea to create a fake Dll file!!!
    Life is Good
    Monday, May 24, 2010 9:26 PM
  • This is a life saver.. Thank you very much...

    Friday, April 8, 2011 5:24 AM