none
Visual Studio 2015 - Error When Renaming Form1.vb (STILL HAPPENING)

    Question

  • Trying to rename Form1.vb in a Windows Forms project immediately and irrecoverably destroys it, so far as I can see.

    The last activity I see on this issue in January of 2016.  It is now one day from 2017.  Where is the fix for this problem??  I cannot rename the default form without immediately blowing up my project.  I hate having to walk on eggshells using a product that is supposed to make life much, much easier...

    Is there at LEAST a dependable way around it??  I can't find one and don't know enough about VS or VB.Net to hackinate one myself.... :-(


    • Edited by djdave238 Friday, December 30, 2016 11:09 PM Typo
    Friday, December 30, 2016 11:00 PM

All replies

  • Hi djdave238,

    Which property of Form1 did you rename?
      a: [Properties] > [Design] > (Name)
        
      b: [Properties] > [Appearance] > Text
        
      c: [Solution Explorer] > Form1.vb
        

    In either case, it should be able to be changed.

    If you cannot change it, please Repair Visual Studio 2015.
      1. [Control Panel] > [Programs] > [Programs and Features]
      2. Select "Microsoft Visual Studio ???" (which you have installed)
      3. Select [Change]
      4. Select [Repair]

    I hope your Visual Studio will work fine.
      
    Regards,
    Ashidacchi
    Saturday, December 31, 2016 4:02 AM
  • Thanks for the reply from Ashidacchi.

    Hi didave238,

    Welcome to the MSDN forum.

    Does your issue is solved or not? If not, could you please provide the detail steps to rename Form1.vb? Like Ashidacchi said, I also tried to rename the default file ‘Form1.vb’ under Solution Explorer or the default form name ‘Form1’ in the Form1.vb[Design] window at the left side of VS, it affects immediately after modification and VS works fine.

    What’s your VS version? Now the latest version of VS 2015 is VS 2015 update 3, if you have not upgrade it, please go to Visual Studio Downloads and download it to install, then create a new VB window form project to check this issue again.

    If the upgrade or repair not work, please have a try with the following to troubleshot this issue:

    1. Run the VS with safe mode:  open an administrative CMD window and navigate to C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE and run these commands: devenv.exe /safemode to check this issue again, it can help us to avoid the installed extensions caused this issue.
    2. Clean up the user data in VS: run the command devenv /resetuserdata
    3. Run the VS as administrator: to excludes the permission issue

    If this issue persists, I need your help to collect the VS runtime logs, please run the command: devenv /log in the evaluated command prompt. And upload the file (%APPDATA%\Microsoft\VisualStudio\Version\ActivityLog.xml) to https://onedrive.live.com/ and share the link here.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, January 2, 2017 8:05 AM
    Moderator