none
Message Viewer Error

    Question

  • I am trying to view the message from a logged fault and I am getting the following error logged to the event log.  I am getting this error because my database is called BizTalkMsgBoxDbDEV1 and not BizTalkMsgoxDb.  Where can I change the name of the database?

    Invalid object name 'BizTalkMsgBoxDb.dbo.ProcessHeartbeats'.

    Source: Microsoft.Practices.ESB.BizTalkOperations.BizTalkQuery

    Method: System.Collections.ObjectModel.Collection`1[Microsoft.Practices.ESB.BizTalkOperations.BizTalkQuery+BTReceiveLocation] ReceiveLocations(System.String)

    Error Source: .Net SqlClient Data Provider

    Error TargetSite: Void OnError(System.Data.SqlClient.SqlException, Boolean)

     

    Tuesday, April 27, 2010 11:57 AM

Answers

  • Hi,

    On the BizTalk Server, you can check the MessageBox name by the following

    1) In BizTalk Admin Console, expand BizTalk Group and then click Platform Settings

    2) Click on Message Boxes. In the details pane you can right click on the message box to check the properties and the property Database will be the message box database name.

    I think you will have to use the default BizTalkMsgBoxDb name if there is nothing in the ESB configuration tool to change that property.

    See this similar thread on this .

     


    Regards,
    Bali
    MCTS: BizTalk Server
    --------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    Tuesday, April 27, 2010 3:41 PM

All replies

  • Hi,

    You must change the "connectionStrings" in the "Web.config" file of the Portal. You can find the location of the Portal in IIS

    Example:
    C:\Projects\Microsoft.Practices.ESB\Source\Samples\Management Portal\ESB.Portal\Web.config

     <connectionStrings>
      <!--<add name="AdminDatabaseServer" connectionString="Network Library=dbmssocn;Data Source=biz64-801-01;Integrated Security=True;Initial Catalog=ESBAdmin;" providerName="System.Data.SqlClient"/>-->
      <!--<add name="EsbExceptionDb" connectionString="Network Library=dbmssocn;Data Source=biztalk2k801;Initial Catalog=EsbExceptionDb;Integrated Security=True;" providerName="System.Data.SqlClient" />-->
        <add name="AdminDatabaseServer" connectionString="Network Library=dbmssocn;Data Source=(local);Integrated Security=True;Initial Catalog=ESBAdmin;" providerName="System.Data.SqlClient"/>
      <!--<add name="EsbExceptionDb" connectionString="Data Source=biztalk2k802;Initial Catalog=EsbExceptionDb;Integrated Security=True;Application Name=Microsoft.Practices.ESB.Portal"/>-->
     </connectionStrings>

    greetings,

    Tomasso Groenendijk

    Tuesday, April 27, 2010 1:32 PM
  • Hi,

    On the BizTalk Server, you can check the MessageBox name by the following

    1) In BizTalk Admin Console, expand BizTalk Group and then click Platform Settings

    2) Click on Message Boxes. In the details pane you can right click on the message box to check the properties and the property Database will be the message box database name.

    I think you will have to use the default BizTalkMsgBoxDb name if there is nothing in the ESB configuration tool to change that property.

    See this similar thread on this .

     


    Regards,
    Bali
    MCTS: BizTalk Server
    --------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    Tuesday, April 27, 2010 3:41 PM
  • This is caused by a very bad assumption in the BizTalkOperationsService that the message box database exists on the same server as the management database.

    Please see my blog for details and a corrected version of the service.

    Thomas F. Abraham

    Wednesday, July 07, 2010 7:37 PM
  • Thks Thomas! Great Job! ;) Your corrections works perfect!

    Many thnks!

    Wednesday, February 16, 2011 12:34 PM