MDS 2012 - After Loading Data into Staging Table (mdm.tblStgMember), data is not visible in the Web UI integration section. RRS feed

  • Question

  • MDS 2012 - After Loading Data into Staging Table (mdm.tblStgMember), data is not visible in the Web UI integration section.

    It is working through the Excel add-in, but not directly through the Database. Aparently the BATCH_ID field isn't being filled automatically.

    Does anyone have an idea of what can be happening?


    Thursday, April 5, 2012 2:13 PM


All replies

  • Hi Bruno

    Try using Entity Based Staging to load your data. Here's a great video that will help you get started:


    More detailed documentation on the different strategies available for bulk importing data here:



    Arunjeet Singh (Microsoft SQL Server Master Data Services)

    • Marked as answer by Challen Fu Monday, April 30, 2012 9:13 AM
    Monday, April 30, 2012 7:50 AM
  • This could be related to your problem :

    I loaded data into the entity (COUNTRY) staging table (with SSMS), I tried to launch the batch through the WebUI.

    The batches status went from Queued to Run to Running and never got to Completed.

    I tried to do the same thing with the Excel AddIn, nothing happened.

    Then I remembered that MDS had been updated a few weeks earlier.

    I tried to update record #4 using the staging table and instead of launching the batch with the WebUI I called the stored procedure [MDS].[stg].[udp_<entity>_Leaf]. This is what happened :

        declare @BatchTagCountry        nvarchar(50)

          set @BatchTagCountry = replace(replace('INS_COUNTRY_' + convert(nvarchar, getDate(), 120), ' ', ''), ':', '');

          insert into [MDS].stg.COUNTRY_Leaf(ImportType, ImportStatus_ID, Batch_Id, BatchTag, Code, Name)
          values (2, 0, null, @batchTagCountry, N'4', N'Test...')

          exec [MDS].[stg].[udp_COUNTRY__Leaf] @VersionName=N'VERSION_1', @LogFlag=0, @BatchTag=@BatchTagCountry

    (1 row(s) affected)
    Msg 468, Level 16, State 9, Procedure udp_COUNTRY_Leaf, Line 1087
    Cannot resolve the collation conflict between "French_CI_AS" and "Latin1_General_100_CI_AS" in the equal to operation.
    Msg 266, Level 16, State 2, Procedure udp_COUNTRY_Leaf, Line 1087
    Transaction count after EXECUTE indicates a mismatching number of BEGIN and COMMIT statements. Previous count = 0, current count = 1.


    When the MDS update occured, the wrong collation had been chosen.

    I created a new MDS database, with the same collation as the Sql Instance, I imported all the packages I previously exported with MDSModelDeploy.

    I tried again and it worked!

    Monday, September 8, 2014 8:16 AM