locked
Debugger "Start Debugging" disabled RRS feed

  • Question

  • I've used the MS debugger for many years like this:

                 devenv /debugexe myProgram.exe

    and it worked without problems. Recently, my machine got upgraded to Windows 7 (64-bit), and a new version of Visual Studio came along (2008). Now the aforementioned technique no longer works.

           For example:

    "C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe" /debugexe c:\windows\system32\calc.exe

    The window comes  up, shows "Calc" solution, "calc.exe" executable. Everything appears normal, ... BUT ... the "Start debugging" button is DISABLED (grayed out),  and I actually cannot start the debugger.

    Incidentaly, If I go to Tools -> Options -> Debugging, and just click OK (without changing anything), the button re-appears,  I can press on it, and the debugging begins.

    But this is utterly irritating.

    What can be done/set to make the "devenv /debugexe" do what it was intended to do -- i.e. start an executable under the debugger ?

    Thanks,

    -- Nick

     

     

     

     

     


    • Edited by Nick.Mon Tuesday, November 29, 2011 4:15 PM
    Tuesday, November 29, 2011 3:57 PM

Answers

All replies

  • Hi Nick,
     
    Welcome to the MSDN forum!
     
    1.   Create a new project (like C# console), will the Start Debugging button enabled?
     
    2.   Check that whether you have more than one project in Visual Studio solution but none of them is set up as a “Set as Startup Project”.
     
    Solution: Right click on one of the project and click on the “Set as Startup Project” now the Start green play button, F5 key and Start Debugging option will be enabled.
     
    3.   To reset VS environment via ‘devenv /resetsetting’ command and try it again.
     
    4.   If still no help, would you mind letting us know which language are you using? You could create a similar APP, please also attach this project, you can upload it to the sky driver, and then share the download link in your post. We try to debug it with our PC.
     
    If you got error messages, please also show the whole error messages in your post. If there's any concern, please feel free to let me know.
     
    Thanks,
     


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, December 1, 2011 2:06 AM
  • 1.    If I create an empty project, the "Start Debugging" button is ACTIVE.

    2.    When I launch "devenv /debugexe", I do not have multiple projects. I have only one -- the one that MS Visual Studio creates for me on the fly. This is how it looks, when I start it up:

      Right-clicking on it, and selecting "Setup as Start-up Project" does nothing.

      The "devenv /resetsetting" did nothing. Everything just as before.

      The language is C++.

      I've downloaded a DEMO to SkyDrive. Here is the link:

    https://skydrive.live.com/redir.aspx?cid=8f9190487bc55141&resid=8F9190487BC55141!107&parid=8F9190487BC55141!105&authkey=!AC9pLNr5QAXRgFA

      This is not executable-specific though. All our executables show this symptom. Even 'calc.exe' shows the same.

    Thanks,

    -- Nick

     

    Thursday, December 1, 2011 9:19 PM
  • Hi Nick,

     

    Glad to receive your reply.

    I downloaded your App and I could debug it like the following screen shot.

     

    In addition, it seems that your VS2008 didn’t show the debug command bar. To manually get the Debug command bar back, see this thread: http://social.msdn.microsoft.com/Forums/en-US/vsdebug/thread/f22d3b34-0e4a-429e-8c22-207aa672d45b/

     

    Sincerely,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Friday, December 2, 2011 4:52 AM
  • Hi Zack, I'm having similar problems as the OP.

    I'm using Visual C# 2010 Express for school assignments and it is not clear to me what is the difference between projects and .cs files, I've been requested to send my assignments as .cs files so everytime I do a new program I save it as .cs file and thats it.

    But suddenly the debug button is disabled, it seems that I need to have a project in the solution explorer so if I start a new project the debug button is enabled again but when I press F5 it debugs the project I just opened, not my .cs file that is also opened. So how do I debug my .cs files?

    Thanks,

    Alex.

    Tuesday, June 17, 2014 3:46 AM
  • @Alex,

    Since this cased has been closed for a long time, please post a new case in this forum, you would get better response from our support expert:)

    Have a nice day,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, June 17, 2014 7:16 AM