locked
Windows 8 Metro Style Apps Javascript Debugging

    Question

  • I have Windows 8 Consumer Preview (8250) and VS2011 Ultimate, not Express. All I want to do is stop at a breakpoint in the default.js script file. I created a project from the Split layout template and just ran it. My javascript debugger console says:

    Visual Studio is not currently attached to a script debug target that supports browser diagnostics.

    I am in debug mode, with Script only debugging configuration. I cannot get any project, including the samples from MSDN to JS debug. Has anyone else had this issue?

    Monday, April 23, 2012 11:05 PM

All replies

  • Nope!

    I have been using VS 11 Ultimate for a while without a problem.  I thought maybe your debug settings might have specified something other that Javascript but if that is the case you cannot bring up the Javascript console.

    I will move this over to the tools forum.  Perhaps they have seen this before.

    -Jeff


    Jeff Sanders (MSFT)

    Tuesday, April 24, 2012 1:09 PM
    Moderator
  • Thanks for the reply Jeff.  Are you using VS 11 for Metro style apps w/ JavaScript?  If so, can you show/tell me your settings?  I would appreciate it very much.  I've spent two days downloading and trying various Metro style MSDN demos and cannot get them to debug.

    Appreciated


    Tuesday, April 24, 2012 7:41 PM
  • I have both VS 11 express and VS ultimate.  They both behave fine.

    Here are my debug settings:

    You may have to reinstall VS as a last resort!


    Jeff Sanders (MSFT)

    Tuesday, April 24, 2012 7:50 PM
    Moderator
  • Same problem here, did you solved? I had VS11 Professional, uninstalled and installed VS11 Ultimate but get the same error



    Andrea
    Wednesday, April 25, 2012 5:36 PM
  • I also reinstalled and cannot get it working.  I have the same settings as Jeff,  but cannot debug.  Ugh...
    Thursday, April 26, 2012 2:14 PM
  • There must be something odd in your environment.  Let's try and track it down!

    Couple of questions:

    1.  Can you debug a Metro .Net app (C# grid app for example)?

    2.  Did you install another browser per chance?

    3.  Can you debug script in IE 10 (f12 brings up developer tools)?

    -Jeff


    Jeff Sanders (MSFT)

    Thursday, April 26, 2012 3:48 PM
    Moderator
  • Also, is it possible you are running on machines that were upgraded from Windows 7?

    -Jeff


    Jeff Sanders (MSFT)

    Thursday, April 26, 2012 5:22 PM
    Moderator
  • I can debug C# code.  I have IE, FireFox, Safari, Chrome, and Opera browsers installed.  I haven't tried debugging in IE 10 yet.

    I did upgrade from Windows 7

    Thursday, April 26, 2012 6:54 PM
  • Hey TR,

    Let's try registering the debugging dlls:

    From an elevated adminstrative command prompt run these commands:

    C:\Windows\System32>regsvr32 "%ProgramFiles%\Internet Explorer\msdbg2.dll"

    C:\Windows\System32>regsvr32 "%ProgramFiles%\Internet Explorer\pdmproxy100.dll"

    C:\Windows\System32>regsvr32 "%ProgramFiles%\Internet Explorer\pdm.dll"

    Let me know if that works for you!

    -Jeff


    Jeff Sanders (MSFT)

    Thursday, April 26, 2012 7:13 PM
    Moderator
  • Getting closer, I registered the 3 dlls as admin, but now I'm getting a message "The script debugger failed to connect to the target process: Acess is denied".  I am running VS11 as administrator.

    Thursday, April 26, 2012 11:42 PM
  • Hello,

    could you contact me directly at mikewong at microsoft.com?  There is some logging that I want to get from you as well as some other diagnostics.  We'll report back to this forum post once we get this one going.

    much appreciated,

    mike

    Friday, April 27, 2012 5:14 PM
    Moderator
  • Hello Mike, jpsanders, all

    Are there any news on this topic? I think I'm having the same issue here. Or similar.

    - I try to start a JS Metro project from VS on Local machine, Debug configuration. 

    - The app does not shows, but you can see it in Task Manager.

    - After a while the Start screen comes back in front.

    - From VS if I stop debugging (which has never actually started) I got error dialog:

    "The script debugger failed to connect to the target process. The remote procedure call failed".

    If it can help, in the past days I experienced and solved a PerfWatson DLL issue, the same you can see here: 

    http://social.msdn.microsoft.com/Forums/en-US/vssetup/thread/530f705b-a16a-435d-bd66-26073eb95337/

    Wednesday, May 09, 2012 3:41 PM
  • Hello again. It seems to me I was able to solve the issue. Here are the steps I've followed:

    - Remove 'Multilingual App Toolkit for Visual Studio 11 Beta' from VS extension manager and then from 'Add remove programs'

    - Remove 'PerfWatson' from VS extension manager, then delete its folder 'C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\Extensions\<some random folder name>' and delete any references to its DLL in the registry

    - Remove Visual Studio by means of running its original Installer and choosing remove (also tried Repair, didn't work)

    - Remove other Visual Studio-related items from 'Add remove programs'. There were two 'Pre Clean Visual Studio-something' items, then some Visual Studio language pack-related items, and a Visual Studio Developer Preview related item. I was able to remove all of them but two. And I had to play with the order of removal in order to make it work.

    After *any* of those steps I was anyway able to run Visual Studio. Just after this last step I was not able to build the project though. Before it, I was able to build the project, but not to debug.

    Then I launched VS install from its original Installer, which just presented me to Install VS (no repair, no remove available). Now I'm able to debug the project. By the way, PerfWatson is not present under Extension manager (nor Multilingual App Toolkit, of course).




    • Edited by GiUmaTo Friday, May 11, 2012 3:36 PM
    Friday, May 11, 2012 3:34 PM
  • Any update on this.

    I had the excact same initial problem as TropicRanger. I ran the 3 dll registrations, and I also get one step closer, with the new "The script debugger failed to connect" error.

    I also upgraded from a Windows 7 with Visual Studio 2011 to Windows 8 RP (build 8400).

    : Thmas


    Monday, June 04, 2012 3:42 PM
  • You might want to try the same steps that helped me solving this issue?
    Monday, June 04, 2012 3:45 PM
  • I have registered the 3 dlls and have now got the error message "The script debugger failed to connect to the target process. Access is denied" error.

    This is running The release preview version of Windows 8 and the Release candidate version of Visual Studio 2012.

    Debugging metro-style apps works for everything apart from script.

    Monday, June 11, 2012 3:11 PM
  • Any news on this topic ? It has been 3 months now...

    Jan

    Saturday, September 01, 2012 6:37 PM
  • I would suggest you post a new Forum post in this forum along with the specific error messages you have and the steps from above that you have tried.  There are several different things listed here and you did not indicate what you have done or what problems you are having.

    Jeff Sanders (MSFT)

    Tuesday, September 04, 2012 12:18 PM
    Moderator