none
configure PHPMyAdmin Extension in Web App to connect to Azure Database for MySQL, Not In-App RRS feed

  • Question

  • I have been trying to connect phpmyadmin installed as an extension in an Azure Web App(windows) to connect and administer an Azure Database for MYSql database for a while now and have hit a wall and am reaching out.

    I have read many technical documents about this, a lot deal with the In-App MySql which i have working no problem in a separate resource group, but i can't seem to find anything specifically related to non In-App Mysql. Some i find but are older documents and the azure interface is not the same or options that are in the document are not showing up in my azure portal.

    I have basically hardcoded my phpmyadmin config.inc.php with "$cfg['Servers'][$i]['host'] = 'dbname.mysql.database.azure.com'; located in d:\home\SiteExtensions\phpmyadmin so it points to my Azure Database for MySQL DB and it does not seem to have an effect. I have even removed the config.inc.php file from that directory and it seems to have no effect on PHPMyAdmin so i'm not sure this is even the correct location for the active config.inc.php file. can someone confirm this?

    So PHPMyAdmin loads in my browser from the webapp at webappname.scm.azurewebsites.net/PHPMyAdmin but i enter the admin credentials from the Azure Database for MySQL, or any other credentials for that matter, and i receive a "Error 403 - This Web App is Stopped" . I think PHPMyAdmin is still trying to go to the In-App Mysql database which does not exist.

    I have modified the firewall on the Azure Database for MySQL to allow the "Outbound IP Addresses" from the Azure Web App properties. so it should not be a firewall issue but how can i tell.

    Also not sure if i need to create a Vnet to link these 2 Apps together but again the documentation i read on connecting an Azure for MySQL DB to a Vnet is also not working out for me. 

    So again i think it's the config.inc.php file with my changes not being read. Or maybe it's something else and i am way off base here. Any suggestions welcome

    Thursday, August 22, 2019 6:48 PM

All replies

  • Hi Carmanet Mark,

    Can you please go through the following document to see if this helps you resolve your issue: Connect an existing Azure App Service to Azure Database for MySQL server (link)

    The items I am looking to address here is to use either the "Allow access to Azure services" firewall setting to ON or explicitly add the IP Address ranges for the region your services are deployed: Azure IP Ranges and Service Tags – Public Cloud (link)

    I want to make sure your firewall setting are correct. You could enable "Allow access to Azure services" as a quick test, and if the solutions starts working then you know it is a firewall setting. If enabling this is not desired, move on to the download link I added and explicitly add the IP Address ranges for the region you are deployed to.

    If it is not a firewall issue, then move onto the connection strings documentation while also being aware of SSL requirement. 

    Please let us know what you find or if you have additional questions.

    Regards,

    Mike


    Friday, August 23, 2019 12:33 AM
    Moderator
  • Thanks Mike,

    Went through it all and no luck so far. does not appear to be a firewall or SSL issue in relation to the Azure Database for MySQL, more on this as you read the post.

    You're links did lead me to MySQL Workbench which connected successfully from my local workstation. I had to add my local IP address into the MySQL DB firewall then it worked. I tried MySQL Workbench in non SSL mode and SSL required and both connected fine as long as the Azure DB for MySQL settings for Enforce SSL was turned off or on. so I believe SSL is working correctly.

    So I guess we can proceed with managing the DB via MySQL Workbench but I would still like to make PHPMyAdmin from the Azure Web App work. I'm really leaning towards my changes in the config.inc.php are not being read by PHPMyAdmin. 

    I am making changes in the d:\home\SiteExtensions\phpmyadmin\config.inc.php as described in the original post but maybe this is not the active location for the file. I can't find another config.inc.php anywhere on the Azure Web App filesystem.

    Monday, August 26, 2019 7:27 PM
  • Hi Carmanet Mark,

    Do you have an Azure Support Plan? If you do, this needs to go to Azure Support for closer inspection. If you do not have an Azure Support Plan, I can have a one-time support request created to have this issue investigated. Please send me your Azure Subscription ID to AzCommunity and I will return the steps to have this investigated. 

    Regards,

    Mike

    Tuesday, August 27, 2019 1:08 AM
    Moderator
  • Hi Mike,

    I currently do not have an azure support plan. I am in the initial stages of trying to port our existing Web Application to Azure so am using a free account to do the proof of concept.

    I have sent my Subscription ID to the email address as requested.

    Thank you.

    Mark.

    Wednesday, August 28, 2019 1:39 PM
  • Hi Mark,

    I just sent you the instructions to have this issue investigated. Please ensure that this gets filed against the App Service and not Azure Database for MySQL, as that is where the issue exists. Please let me know if you have additional questions.

    Regards,

    Mike

    Wednesday, August 28, 2019 4:14 PM
    Moderator