none
FTP adapter, prevent logging to event log RRS feed

  • Question

  • I have a BizTalk application wich is using the FTP adapter to retrieve files from a PLU. The problem is that the PLU is powered off when not in use, and that generates a lot of warnings into the event log. The polling is scheduled between 09:00 and 17:00, but the PLS is often switched off in that time span.

    The warning is:

    The adapter "FTP" raised an error message. Details "Unable to connect to FTP server "192.168.12.185" as user "inn". Inner Exception details: "No FTP server found on the specified address. ". ".

    Is there any way to prevent BizTalk from logging this warning to the Application event log (for a given IP adress)? The administrators are not happy with all these messages filling up the event log.


    Idar H.

    Monday, December 7, 2015 8:18 AM

Answers

All replies

  • If receive location is turned on it will always log errors in eventvwr if source is not discoverable. 

    So the workaround I can think of is to write a program which always runs as windows process(or scheduled to run) and enables/disables the receive location at configured/desired time.

    Please refer the below articles which talks in detail about how to programmatically enable_or_disable receive locations.

    Programmatically Enable or Disable Receive Locations

    Stopping and Starting Orchestrations, Send Ports, and Receive Locations Programmatically 


    Thanks,
    Prashant

    My BizTalk Blog
    -------------------------------------------------------------------------
    Please mark this post accordingly if it answers your query or is helpful.

    • Marked as answer by Angie Xu Wednesday, December 16, 2015 2:41 AM
    Monday, December 7, 2015 8:25 AM
  • I solved it by making a Windows service which checks the ftp location every 5 minutes, and if the server is Down and the receive location is enabled, it disables the location. If the server is on and the receive location is disabled, it is enabled. That solved the problem.

    Thanks.


    Idar H.

    Wednesday, December 16, 2015 7:03 AM