The file________ is not a valid image file ??? HELP


  • I only started playing with Deep Zoom a couple of days ago and everything had been going great.

    2 DAYS LATER:  Everytime I try to "add image" (any image) i get the error message "The file________ is not a valid image file" , regardless of file size or whether its a .jpg .tiff .png etc.... I tried uninstalling and re-installing, rebooting etc.... nothing seems to stop the problem.

    Any ideas?

    Wednesday, December 31, 2008 2:55 AM

All replies

  • Hi G,
    Are you opening an existing project or creating a project from scratch?

    Sunday, January 11, 2009 5:41 AM
  • either.... same problem for both.

    Sunday, January 11, 2009 8:42 AM
  • I am experiencing the same problem.  I can no longer import even files that I have previously imported into other projects with no problem.  Any ideas?

    Friday, January 16, 2009 7:54 AM
  • Me too, same exact thing...worked yesterday. Today is a no go

    Help Please


    Friday, January 16, 2009 3:23 PM
  • More info to hopefully help:

    I'm running Vista Ultimate 64, SP1.

    When I attempt to import an image, it works for a while, then ultimately gives the error message.  When I look in the directory for the project, in '/Working Data', I can see that several of the tiles have been created.  Sometimes it appears that all of the tiles in the numerical folders have been created, whereas sometimes the last few folders (like /12 - /15) are empty.

    I attempted installing that C++ thing mentioned in the other thread reporting this problem, but it did not work.

    Occasionally, maybe one out of 10+ times, for no reason I can discern, I am able to successfully import an image.  I don't think anything about the images I try is the problem, as I have tried many different file types saved with different compressions using different software (photoshop, irfanview, etc.).

    Any help is much appreciated, as I am stuck unable to use the software.  Thanks,

    Sunday, January 18, 2009 3:20 AM
  • Hi everyone,
    I'm looking into this right now. We believe this issue is fixed in our more recent builds, but the reason for it working for a while but stopping is really weird.

    Tuesday, January 20, 2009 1:55 AM
  • Having the same problem here. Happens when using Deep Zoom Composer, but also get an exception when using DeepZoomTools.dll:

    System.ArgumentOutOfRangeException: capacity was less than the current size.
    Parameter name: capacity
       at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
       at System.Collections.Generic.List`1..ctor(Int32 capacity)
       at Microsoft.DeepZoomTools.SparseImageCreator.Create(ICollection`1 images, String destination)
       at Microsoft.DeepZoomTools.ImageCreator.Create(String source, String destination)

    This happens randomly.
    Wednesday, January 21, 2009 5:31 PM
  •  Hi,

    I've been getting "random" invalid image file messages recently - random in that if I create another deepzoom project with the offending images it manages to load it up. All I am doing is creating a fresh project, and adding in 206 files (combined total of 203MB).

    This occurs on XP SP3, Win2003, Win2008 so its not limited to one PC.

    I've had the issue with the October and December 2008 releases.

    What I have noticed is that my page file ramps up to nearly 90% before it errors, so I'm wondering if is related (XP actually popped up a "you need more virtual page file space" message at one point).



    Monday, January 26, 2009 10:20 AM
  • Hi mark (and others),
    These issues are loosely related to too much memory being used by the encoding process. This is something that we are looking into fixing for our upcoming release.

    Kirupa :)

    Wednesday, January 28, 2009 6:06 PM
  • I have the same problem.  Just downloaded and installed composer yesterday.  I cannot add a single image, and always get this error right from the start, no matter what, so I can't use it at all.  Is new release coming soon?
    Wednesday, February 04, 2009 3:06 PM
  • I will be posting a new preview sometime in the next day or so :)


    Monday, February 09, 2009 11:04 PM
  • Yup. Same problem for me. Just downloaded it and every file I try I get this error. This really sucks. I have Expression Blend 2 SP1 also installed. 
    Sunday, February 15, 2009 6:37 AM
  • Please let us know when and where you post this new release kirupa.

    I attempted to use Expression Web and Blend about 8 months ago.  When I installed it, it completely re-configured my VS UI.

    A couple of weeks ago, I thought I would try Expression Blend 2 SP 1 because there seems to be a lot of Silverlight samples, etc. that I can now use.  With the Deep Zoom composer I had the same problem as above.  I can not bear the thought of having to go to Flash, but it is becoming apparent that may be my only viable choice.

    We look forward to hearing when Deep Zoom is actually functional for the masses.

    Sunday, February 15, 2009 1:49 PM
  • Hi Kirupa,

    I updated to the Feb 17th release of DZC, but this issue is still present - once opening a large(ish) jpeg fails nothing else loads after that... Hope a patch is not too far down the road?

    Thursday, March 05, 2009 7:40 PM
  • Does any one have a resolution/explanation for this issue yet? It is getting to be a bit frustrating.



    Tuesday, April 14, 2009 9:14 AM
  • I'm getting this error and wonder what's going on...
    Wednesday, April 22, 2009 2:11 AM
  • I am having the same issue, can't import single jpg file into deep zoom.
    Wednesday, April 29, 2009 1:52 PM
  • Same issue here... this is totally frustrating... Please don't let me go back to Flash...
    Wednesday, April 29, 2009 8:42 PM
  • I wonder what it will take to get this fixed...?  How many others will need to have this same problem and post here???
    Thursday, April 30, 2009 12:23 PM
  • Same exact problem. Windows XP SP3.

    Deep Zoom Composer is a NO GO!
    Friday, May 01, 2009 1:01 AM
  • jpgs, pngs, tiff, bmp don't work! Not even simple small jpgs.
    Friday, May 01, 2009 1:10 AM
  • Composer start working and importing images next day. As I'am preparing for Microsoft conference to demonstrate DeeZoom I am just hoping that this will work for a week to tile a images. But Murphy is always there at the end and that I'am scared.

    BTW.. Kirupa are you here?
    • Edited by Avivo Friday, May 01, 2009 7:55 PM
    Friday, May 01, 2009 7:51 PM
  • Bad day... don't like jpg's today.
    Sunday, May 03, 2009 8:18 PM
  • Just a quick question - do you have .NET 3.5 SP1 installed by any chance? That is the only missing component I can think off that would cause this error.


    Monday, May 04, 2009 7:22 AM
  • I have the same problem with the following setup -->

    MS Windows Vista Ultimate
    .NET 3.5 SP1 is installed
    Total number of images = 250
    Total image file size = 120MB
    Tuesday, May 05, 2009 8:29 AM
  • I have finished my Deep Zoom presentation.  Yes I have SP1. I have switch to other computer and import was working ok for now.

    I am posting my general experience with DZC.  Lot of other things wasn't working quite as expected.

    > app crash time to time (at exporting- progress bar blink and nothing was happening, it creates few folders but not everything that should )
    > when reopen DZC from chrash it few times some of elements in compose board was missing and i have to put in compose board again
    > exported layout isn't 100% as it is in DZC (images were with offset)
    > images/library box has some design problem at the bottom

    What i miss:
    > When you update some of jpg and you have to import it again it should be some linking to update that asset on compose board
    > Theoretical it should be infinitive zoom, but if you scale down image quite a lot then you cant export it... button is grey..  How to know this from compose board, other the trying
    > gruping objects on compose board
    > Asset in library (should be folders to have better view of assets when you have many)
    > Taging and meta dont work (they work in import tab but not in compose, and i would like to have URL to asset and if possible to linking for update if this is possible)
    > Layers tab... didin't find any use as it is
    > No good docs how big images are suitable for import... i try also with 5000 px widh image to have some effect, but is seem to have problem to export if there are lot of big images that size
    > Some sort of thumbnails for switching between images in compose mode... scrolling is quite a pain and slow. To switch to one image and fit it on screen.
    > Save as in file menu
    > probably for start users.. direkt icon.. view it in browser

    • Edited by Avivo Tuesday, May 05, 2009 6:49 PM
    Tuesday, May 05, 2009 6:46 PM
  • I got the same problem: start DZC, import one image, I only get the error Message "The file _______ is not a valid image file".

    Doesn't matter if the picture is a small jpg or a way huge tiff.

    Comp is Vista x64 with 8GB Ram.

    Checking my DZC version I found it to be the feb'9 - I uninstalled and fetched the most recept April'09 Version, but still the same problem.

    Kind regards,
    Thursday, June 11, 2009 8:37 PM
  • Is there an answer to this thread yet???

    I just started to use bu I have no success with the images I inteded to use.

    Some small images work (2-5MB) but when I try to use the images I want (300MB>) it says the above error...

    I have noticed that the picassa veiwer I have displays "Not a valid image". I assumed it was because they did not want to render such large images... I wonder if it is connected though. The images open fine with other tools (e.g. Windows Fax viewer).

    They are images that were stitched together witha  line scan camera.

    Yes I have .Net 3.5 SP1
    Collin Jasnoch Systems Development Enginner
    Monday, November 16, 2009 3:41 PM
  • I had the same problem today and I found out, that these images could not be opened with paint either.

    So I split up my file into multiple smaller ones (which was actually no problem because they were created dynamicly) and it worked. So this helped me and it could be worth a trial.


    Thursday, April 01, 2010 11:53 PM
  • I'm having the same problem here, but only with my computer at work; the same exact file opens fine with my computer at home!

    Both computers have 4GB RAM, but the home computer is an AMD Phenom quad-core 64 with Vista 64, and the work computer is an Intel 32-bit dual-core running WinXP Pro.

    Thursday, April 22, 2010 4:57 PM
  • Okay, Kirupa I think I've discovered part of the problem here.


    I just tried opening a jpg file that is 23.3MB in file size, with dimensions of 7400px x 5700px, and DZC was fine with opening that image.

    So I took the same image and scaled the canvas size (in GIMP) to 7400px x 14000px in order to be of the same dimensions as the file that I have been getting the error with, while keeping the file size essentially the same at 24.1MB (the extra canvas space is just "white" space).

    This reproduced the error.

    So basically I think this means that actual file size may not be an issue (unless the dimension error as described only occurs above a certain threshold, which I did not test). What seems to be at issue is the dimensions of the file.

    Coincidentally, this may also have something to do with why when I successfully create a DZC project with my home computer using my 7400px x 14000px jpg that the full-image thumbnails don't show my full image--instead they show 2/3 of the image, vertically, and then repeat the 2nd third of the image as the last third of the thumbnail; I've been fixing these manually.

    I hope this info helps!

    Thursday, April 22, 2010 5:50 PM
  • Good point. My file dimensions was 21600x10800 600GB. I could not get it to work until I redused the resolution to 5400x2700 42GB. My version of DZC is 1.0.1927.1. System Vista 64 with 8GB of ram.

    Has this been fixed?

    Friday, April 23, 2010 1:32 PM
  • I too have the latest version of DZC, and it gives me the error... Hopefully Kirupa sees my message above. But Jerry, I'm willing to bet that even if you took that 21600x10800 600MB (I'm assuming you meant MB, not GB) image and re-scaled it to something like 10800x10800 as a test image that it would then actually work (it might take a while, but I'm betting you won't see the same error). In case you feel like testing it to see if my theory holds.
    • Proposed as answer by aridolan Saturday, April 24, 2010 8:38 PM
    Friday, April 23, 2010 2:40 PM
  • I experienced this problem several times when dealing with large files. The solution I use is exporting to HD View and DeepZoom from Photoshop, using the plugin that is included in the HDView Utilities. This way it is possible to create the files pyramid from any picture that can be loaded into Photoshop.

    The plugin can be loaded from:


    Saturday, April 24, 2010 8:46 PM
  • Interesting workaround!  Too bad there isn't a similar plug-in for GIMP...
    Monday, April 26, 2010 2:48 PM
  • Hi All


    I think it is related to the file format.   When I copy JPG images directly from my Kodak digital camera it imports fine, but when I convert these images in Picasa with exactly the same dimensions and save the changes it does not import any more.

    Sunday, June 13, 2010 12:31 AM
  • Not work for some images. Load fine in paint, whatever...

    Why import stop after a single error?



    Thursday, July 15, 2010 7:22 AM
  • Stil not work!
    Thursday, July 15, 2010 7:31 AM
  • Ok, this may be a bit out of topic here, but I couldn't start a new topic, and I wanna go to bed. So, here goes:

    (Comes up (your program).exe in the title bar. Then in the main text part says (such and such.dll is not a valid picture file. Well DUH!, it is a .DLL))

    I was a little behind on my Windows Updates, due to having a long spell without internet. I know this problem is sort of asked somewhere else, but those people are having issues with real pic files. This error is popping up on me constantly. I just started updating again(AMD XP2000, 2GB 400Mhz, Win XP Home SP2(when I installed SP3 when it first came out, my PC crashed, had to uninstall)). I wouldn't be so worried about it if they were pic files, but I think everyone knows that a DLL file is not a pic file. Other then the pain of clicking the box, everything else seems ok. All updates are installed now, except SP3. The updates that seem to "given" my PC this "bug" are #KB979309 and #KB978601. If I don't hear anything, I will probably try to unstall this updates, but with them being security updates, I don't really wish to do this. HELP!!

    Bryan G.

    Thursday, July 22, 2010 5:57 AM
  • Just checking in to see if there's been any progress on this?
    Wednesday, September 29, 2010 8:44 PM
  • Hi Kirupa,

    I think what you say about memory is correct.  If I load a "small" 30MB bmp, everything works fine.  If I try and load a 487MB bmp, 332700x500px, Format24bppRgb then I get the invalid file message.

    My goal is to assemble a large deep zoom image, 670000x500px in overall size.   I am generating the source images using C# and GDI+  so I can assemble any size source image that would work well as input to deep zoom.

    Can you reccomend best practices for how to get the images assembled into the deep zoom composer, and how to create a really big deep zoom image, if I am having trouble loading just one ~500MB image?



    • Proposed as answer by C0ST3LL0 Thursday, December 02, 2010 2:19 AM
    Tuesday, November 02, 2010 10:51 PM
  • I am brand new to DZ. Just downloaded it yesterday. I believe that there is something about the memory but there is definitely an issue with white space. I scanned some photos to my computer. A 4x6 photo, so when it scanned there was white space on the edges. This caused DZ to give me the error that the image was not valid. I then tried to import the exact same image after the white space had been cut and it worked.
    Thursday, December 02, 2010 2:22 AM
  • I can't believe that nearly 3 years later this is still a problem. I'm on XP, SP3 with the latest DZC and it isn't loading a moderately sized jpg. What's going on Microsoft???




    • Proposed as answer by xnay Sunday, June 19, 2011 9:05 AM
    Monday, April 25, 2011 10:31 AM
  • I can't believe that nearly 3 years later this is still a problem. I'm on XP, SP3 with the latest DZC and it isn't loading a moderately sized jpg. What's going on Microsoft???




    Yeah, almost 3 years and I still get this message when opening an image file, no matter if it's jpg, png, tiff... Looks like Deep Zoom is dead. And if the file is really wrong then what are the specs for the right input file?
    Sunday, June 19, 2011 9:08 AM
  • I gave up on Deep Zoom.  Nice idea.  Obviously MS does not have any plans for it.  Other than the email updates I receive once every few months from this thread, I never hear of DZ being used by any one anywhere.


    I am dropping my subscription to this thread.


    RIP DZ.

    Thanks! Steve
    Monday, June 20, 2011 2:49 PM
  • Seriously, this is pathetic!
    The thread is just abandoned by the MS support? I downloaded the latest version of the Deep Zoom Composer an can't get it to import pictures.
    Come on, MS, you can't seriously be unable to fix this?!
    Tuesday, August 16, 2011 8:45 AM
  • My advice:

    Drop Deep Zoom Composer, it's slow, it crashes and it doesn't handle big images.

    Use the Deep Zoom Tools (http://www.silverlight.net/archives/whitepapers/deep-zoom-tools) and the DZconvert.exe command. You'll find all you need in the readme file.

    With this light command prompt, its takes 10sec to convert 10k images to Seadragon pyramid format and it generates the XML. 

    Combined with Photoshop/Indesign you can get same result as Deep Zoom Composer. 

    Tuesday, August 30, 2011 12:34 PM