locked
A potentially dangerous Request.Path value was detected from the client (?). RRS feed

  • Question

  • User70883468 posted

    I am using Webhandler to upload images to the server. I want to send the folder name so on that folder the images will save. I am using this URI format and got the below error.

    builder.Path = builder.Path.TrimEnd('/') + "/Services/FileReceiver.ashx?foldername=" + folder;

    this.Uri = builder.Uri; 

    Also I added the following line in the web.config but still having the issue.

    <httpRuntime requestValidationMode="2.0" />

      

    A potentially dangerous Request.Path value was detected from the client (?).

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.Web.HttpException: A potentially dangerous Request.Path value was detected from the client (?).

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace: 

    [HttpException (0x80004005): A potentially dangerous Request.Path value was detected from the client (?).]
       System.Web.HttpRequest.ValidateInputIfRequiredByConfig() +8884233
       System.Web.ValidateRequestExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +35
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +184
    


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

    Monday, May 24, 2010 7:19 AM

All replies

  • User1268001420 posted

    hey arun

     

    check this out i too was looking for solution for this problem

     

    http://www.cryer.co.uk/brian/mswinswdev/ms_vbnet_server_error_potentially_dangerous.htm

     

    finally found it .

     

    Monday, May 24, 2010 10:24 AM
  • User387574261 posted

    pbarunkumar, have you resolved this issue? I experience the same problem, any help will be very appreciated.


    I also added 

    <httpRuntime requestValidationMode="2.0" />

    Wednesday, June 9, 2010 12:14 PM
  • User70883468 posted

    Hi,

    Not yet found any solutions still having the same problem. 

    Wednesday, June 16, 2010 8:25 AM
  • User1452995550 posted

    <system.web>
            <httpRuntime requestValidationMode="2.0" requestPathInvalidCharacters="" />
            <pages validateRequest="false" />
    <system.web>
            <httpRuntime requestValidationMode="2.0" requestPathInvalidCharacters="" />
            <pages validateRequest="false" />

    this worked form me. 


    Friday, October 29, 2010 9:11 AM
  • User-1778201474 posted

    I found it thanks for sharing.

    Thursday, January 21, 2016 10:47 AM