locked
The configuration section 'system.web.extensions' cannot be read because it is missing a section declaration RRS feed

  • Question

  • User1440393760 posted

    My system: I have installed Windows 7, VS2010 and .NET40 and ASPAJAXExtSetup.msi

    I used to work with vs2008 and .NET3.5, after installing VS2010 I upgraded to .NET40. I dont think that is the issue here, but it might be something you need to know :)

    My problem seems to arise from something within IIS, but I have no idea.

    I'm getting the error below.

    Error Summary

    HTTP Error 500.19 - Internal Server Error

    The requested page cannot be accessed because the related configuration data for the page is invalid.

    Detailed Error Information
    Module IIS Web Core
    Notification Unknown
    Handler Not yet determined
    Error Code 0x80070032
    Config Error The configuration section 'system.web.extensions' cannot be read because it is missing a section declaration
    Config File \\?\C:\inetpub\tickets\web.config
    Requested URL http://www.tickets.com:80/
    Physical Path
    Logon Method Not yet determined
    Logon User Not yet determined
    Config Source
       45: 	</connectionStrings>
    46: <system.web.extensions>
    47: <scripting>

    My web.config:


    <?xml version="1.0"?>
    <configuration>
        <connectionStrings>        
        </connectionStrings>
        <system.web.extensions>
            <scripting>
                <webServices>
                    <!--http://weblogs.asp.net/andrewfrederick/archive/2008/02/18/a-client-side-ajax-login-for-asp-net.aspx-->
                    <authenticationService enabled="true" requireSSL="false"/>
                </webServices>
            </scripting>
        </system.web.extensions>
        <system.web>
            <httpHandlers>
                <add path="ChartImg.axd" verb="GET,HEAD" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
            </httpHandlers>
            <compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
                <assemblies>
                    <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
                    <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                    <add assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
                    <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></assemblies></compilation>
            <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID">
                <namespaces>
                    <clear/>
                    <add namespace="System"/>
                    <add namespace="System.Collections"/>
                    <add namespace="System.Collections.Specialized"/>
                    <add namespace="System.Configuration"/>
                    <add namespace="System.Text"/>
                    <add namespace="System.Text.RegularExpressions"/>
                    <add namespace="System.Web"/>
                    <add namespace="System.Web.Caching"/>
                    <add namespace="System.Web.SessionState"/>
                    <add namespace="System.Web.Security"/>
                    <add namespace="System.Web.Profile"/>
                    <add namespace="System.Web.UI"/>
                    <add namespace="System.Web.UI.WebControls"/>
                    <add namespace="System.Web.UI.WebControls.WebParts"/>
                    <add namespace="System.Web.UI.HtmlControls"/>
                </namespaces>
                <controls>
                    <add tagPrefix="asp" namespace="System.Web.UI.DataVisualization.Charting" assembly="System.Web.DataVisualization, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
                </controls>
            </pages>
            <sessionState mode="InProc" timeout="60"/>
            <authentication mode="Forms">
                <forms name=".MyCookie" slidingExpiration="true" timeout="60" cookieless="AutoDetect" loginUrl="/login/" protection="All" defaultUrl="/">
                    <credentials passwordFormat="SHA1"/>
                </forms>
            </authentication>
            <customErrors mode="Off" defaultRedirect="/contact.aspx">
                <error statusCode="404" redirect="/contact.aspx"/>
            </customErrors>
            <roleManager domain="192.168.0.103" enabled="true" cacheRolesInCookie="true" cookieName=".ASPXROLES" cookieTimeout="60" cookiePath="/" cookieRequireSSL="false" cookieSlidingExpiration="true" cookieProtection="All" defaultProvider="AccessRoleProvider" createPersistentCookie="false" maxCachedResults="25">
                <providers>
                    <clear/>
                    <add name="AccessRoleProvider" connectionStringName="conn1" applicationName="/tickets" type="Samples.AccessProviders.AccessRoleProvider"/>
                </providers>
            </roleManager>
            <membership defaultProvider="AccessMembershipProvider" userIsOnlineTimeWindow="30">
                <providers>
                    <clear/>
                    <add name="AccessMembershipProvider" type="Samples.AccessProviders.AccessMembershipProvider" connectionStringName="conn1" requiresQuestionAndAnswer="false" applicationName="/tickets" minRequiredPasswordLength="6" enablePasswordRetrieval="false" enablePasswordReset="true" requiresUniqueEmail="true" minRequiredNonalphanumericCharacters="0" passwordFormat="Hashed"/>
                </providers>
            </membership>
        </system.web>

        <system.webServer>
            <validation validateIntegratedModeConfiguration="false"/>
            <modules runAllManagedModulesForAllRequests="true">
            </modules>
            <handlers>
                <add name="ChartImageHandler" preCondition="integratedMode" verb="GET,HEAD" path="ChartImg.axd" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
            </handlers>
            <rewrite>
                <rules>
                    <rule name="ordermanagement">
                        <match url="^eventmanager/ordermanagement/([0-9]+)"/>
                        <action type="Rewrite" url="ordermanagement.aspx?eventid={R:1}"/>
                    </rule>
                </rules>
            </rewrite>
        </system.webServer>
    </configuration>

     

    I then checked out this page: http://mvolo.com/blogs/serverside/archive/2007/12/08/IIS-7.0-Breaking-Changes-ASP.NET-2.0-applications-Integrated-mode.aspx

    And now Im trying this:
    %windir%\system32\inetsrv\Appcmd migrate config "c:\inetpub\tickets"

    But I get the error:
    ERROR ( message:Cannot find APP object with identifier "c:\inetpub\tickets"". )
    I also tried:
    %windir%\system32\inetsrv\Appcmd migrate config "tickets"

    But still no luck..
    What am I doing wrong?

    Thursday, April 15, 2010 5:13 PM

All replies

  • User1440393760 posted

    I have now done this:
    "appcmd list sites"

    I then see this:
    SITE "Tickets" (id:1,bindings:http/*:80:www.tickets.com,state:Started)

    Next I do:
    appcmd migrate config "Tickets"

    I then get:
    ERROR ( message:Cannot find APP object with identifier "Tickets". )

    What am I doing wrong?

    Friday, April 16, 2010 6:48 AM
  • User744767459 posted

    Hi,

    This issue not caused by the web.config migration. If you update you application to .Net Framework4.0, but assign this application to an application pool running under .Net Framework3.5 or previous version, you will encounter this error.

    You can assign this application to an .Net Framework4.0 application pool in IIS to fix issue. If you have any problem, please update here.

    Wednesday, April 21, 2010 10:30 PM
  • User-855406380 posted

    Hi,

    This issue not caused by the web.config migration. If you update you application to .Net Framework4.0, but assign this application to an application pool running under .Net Framework3.5 or previous version, you will encounter this error.

    You can assign this application to an .Net Framework4.0 application pool in IIS to fix issue. If you have any problem, please update here.

     

     

    I'm getting this error too, but my app is already running on a 4.0 application pool.

     Help?

     

    Wednesday, May 5, 2010 9:19 AM
  • User744767459 posted

    Hi,

    Could you please post your web.config here?

    Thanks.

    Thursday, May 6, 2010 3:01 AM
  • User-855406380 posted

    Hi,

    Could you please post your web.config here?

    Thanks.

     

     

     

    It's erroring at:

    <system.web.extensions>
            <scripting>
                <scriptResourceHandler enableCompression="true" enableCaching="true"/>
            </scripting>
        </system.web.extensions>

     

     Here's the web.config contents,

     

     <?xml version="1.0"?>
    <configuration>
        <appSettings>      
        </appSettings>
        <connectionStrings>       
        </connectionStrings>
        <system.web>
            <httpRuntime maxRequestLength="8192"/>
            <globalization culture="en-US"/>
            <pages styleSheetTheme="Professional" enableEventValidation="false" controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID">
                <controls>
                    <add tagPrefix="ajaxToolkit" namespace="AjaxControlToolkit" assembly="AjaxControlToolkit"/>
                    <add tagPrefix="widget" src="~/_widgets/select_user.ascx" tagName="select_user"/>
                    <add tagPrefix="BDP" namespace="BasicFrame.WebControls" assembly="BasicFrame.WebControls.BasicDatePicker"/>
                </controls>
            </pages>
            <compilation debug="true" targetFramework="4.0">
                <assemblies>
                    <add assembly="CrystalDecisions.CrystalReports.Engine, Version=12.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304"/>
                    <add assembly="CrystalDecisions.ReportSource, Version=12.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304"/>
                    <add assembly="CrystalDecisions.Shared, Version=12.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304"/>
                    <add assembly="CrystalDecisions.Web, Version=12.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304"/>
                </assemblies>
            </compilation>       
            <authorization>
                <deny users="?"/>
                <allow users="*"/>
            </authorization>
        </system.web>
        <system.web.extensions>
            <scripting>
                <scriptResourceHandler enableCompression="true" enableCaching="true"/>
            </scripting>
        </system.web.extensions>
    </configuration>

     

    Thursday, May 6, 2010 7:26 AM
  • User744767459 posted

    Hi,

    Please check the machine.config file located in  C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config directory. Does the following configuration section declaration exists?

    <configuration>
     <configSections>

      <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
       <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
        <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
        <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
         <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere"/>
         <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
         <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
         <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
        </sectionGroup>
       </sectionGroup>
      </sectionGroup>

    </configProtectedData>

    </configuration>

    Note: if you intend to manually edit the machine.config file, please remember to backup it firstly.

    Friday, May 7, 2010 3:52 AM
  • User-855406380 posted
    -- double post, oops, see below --
    Friday, May 7, 2010 7:24 AM
  • User-855406380 posted

     Leo,

     

    Yeah there's a section for that:

     

    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
                <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
                    <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
                    <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
                        <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere" />
                        <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
                        <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
                        <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
                    </sectionGroup>
                </sectionGroup>
            </sectionGroup>

    Friday, May 7, 2010 7:25 AM
  • User-345632295 posted

    I am seeing the same problem with one of our IIS 7.0 machine.  I am posting a little bit of extra information we found out

    1) I am getting the same error when I tried to open any section, eg. asp.net Machine Key, IIS default document.

    2) I did a filemon trace and found that IIS manager and the worker process was somehow reading the version 2.0 machine.config even though the worker process is set to 4.0.  I did the same filemon trace on another machine and it is reading the 4.0 machine.config.

    I think there's something in the registry that tells IIS which config to read.. but I couldn't figure it out. 

    Tuesday, May 11, 2010 7:45 PM
  • User-855406380 posted

     Yeah I'm still having this problem. Section is commented out till a resolution can be found :(

    Tuesday, May 11, 2010 7:50 PM
  • User744767459 posted

    Hi,

    Could you please send the applicationHost.config file located in C:\Windows\system32\inetsrv\config to me at: liangliang(dot)tang(at)hotmail(dot)com?

    I'll try reproduce this issue. Thanks.

    Tuesday, May 11, 2010 8:27 PM
  • User2055656454 posted
    anyone find a fix to this yet? I am having the same problem and need to get a site up and running
    Tuesday, May 18, 2010 11:28 AM
  • User-47214744 posted

    Do you by any chance have nested applications that are in 2.0, for example the "/" application is .net 4.0 and then /App is 2.0?

    Anyway, you should be able to prevent the problem by adding the declaration of the sections at the top of your web.config:

    So just add right after the <configuration>:

      <configSections>

        
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
          
    <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
            
    <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
            <
    sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
              
    <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere"/>
              <
    section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
              <
    section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
              <
    section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
            </
    sectionGroup>
          
    </sectionGroup>
        
    </sectionGroup>

     

     

    Tuesday, May 18, 2010 1:36 PM
  • User-855406380 posted

     I didn't have a nested app, but this still fixed the problem for me. I put this stuff back at the top (it was removed going from 3.5 > 4.0 automatically), and then uncommented my compression/caching tags, and all is well.

     

    Mitch

    Wednesday, May 19, 2010 6:56 PM
  • User-180511670 posted

    CarlosAg,

    Thanks for your post. I do have a 2.0 app nested within a 4.0 app and I'm getting the subject error.  I've been googling a solution and stumbled upon your post.

    All pages in the asp.net 4 app work fine. As soon as I nav to a page within the 2.0 app (which is just a subfolder in the root app), I get the error. I have configured IIS7.5 for each app. The 2.0 folder was converted to an app and it runs in a 2.0 app pool. The 4.0 app is the root app and it is set to run in a 4.0 app pool.

    It appears that my 4.0 app is trying to propogate its settings down to the 2.0 sub app.  Note that my error message refers to the 4.0 web.config of the root app, even though I am trying to browse a page in the sub app.

    Any ideas how to keep these 4.0 settings from propogating to nested app?

    Regards,
    -e

    Monday, July 26, 2010 12:07 PM
  • User1953795828 posted

    I'm getting this error too on our test server, which is Windows Server Web 2008 SP1 (32 bit).

    Our production servers, which are Windows Server 2008 64 bit, running exactly the same webapp, are doing fine...

    And yes, the app pool runs on 4.0

    Please fix this bug!

    Thursday, November 4, 2010 10:04 AM
  • User-286677902 posted

    I also meet a problem like this

     "

    HTTP Error 500.19 - Internal Server Error

    "

    "








    Config Error The configuration section 'standardEndpoints' cannot be read because it is
    missing a section declaration

    "

    and I set the applicationPool  to .net framework 4

    Thursday, November 11, 2010 8:55 PM
  • User-47214744 posted
    This is a common problem caused by the web.config included in applications developed for .net 3.5. If you want to run it in .NET 4.0, you will need to clean up the web.config to remove all of that duplicated sections that unfortunately were required for 3.5. Alternatively you could just change the application pool to run in .net 2.0 which is what it seems these applications were developed on anyway.
    Thursday, November 11, 2010 11:58 PM
  • User608976117 posted

    For some reason by adding system.web.extensions to the Web.config, overrides the system.web.extensions group (by default in the machine.config). The solution is:

    1. Delete the System.Web.Extensions from your web.config if you don't need it. (it will use the default values from the machine.config)

    2. Add <sectionGroup name="system.web.extensions"   from the machine.config into the Web.config section group

     

    Thanks,

    Sebastian

    Monday, March 7, 2011 11:55 AM
  • User199479068 posted
    I've experienced this error when running 32bit website applications in 64bit environment. There are several ways to overcome this issue:
    - recompile your website with AnyCPU or 64bit mode
    - change the website application pool to support 32bit apps - this can be done by selecting an app pool in IIS manager and in then changing the Advanced Settings > Enable 32-bit applications to true
    Friday, August 26, 2011 7:12 AM
  • User-482116369 posted
    While your solution didn't work for me, it got me on the right track so thank you.

    What I had was a <component> section with some VBScript in it and I was getting this error. I haven't tried actually running my code yet, but at least my page renders again, with this code inserted immediately after the <configuration> tag.

    <xml><configSections>
        <section name="component" type="component"/>
    </configSections>
    </xml>
    To be honest, I have no idea whether this is even valid or correct, but like I said, my page renders again, so I guess we'll see when I go to run my scripts. Assume that if I don't postback (ack, nerd humor, lol) that it worked for me.

    Cheers ;)

    p.s. WTH is up with the redonculous post text editor and syntax on this site?! ACK!! Seriously I have to put <br /> after every line just to get line separation? Get a clue, whoever designed the WYSIWYG editor. Rawr!!
    Wednesday, November 2, 2011 8:39 PM
  • User746887255 posted

    Adding the section groups at the top solved this issue for us.

    Cheers

    Thursday, May 3, 2012 10:16 AM
  • User-2117172214 posted

    http://www.morgantechspace.com/2013/11/The-configuration-section-system-web-extensions-cannot-be-read-because-it-is-missing-a-section-declaration.html

    The issue resolved for me after adding the following configuration setting in my webconfig file

    <configSections>
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
    <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
    <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
    <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
    <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere"/>
    </sectionGroup>
    </sectionGroup>
    </sectionGroup>
    </configSections>

    Tuesday, November 19, 2013 3:47 AM
  • User2117807568 posted

    Try setting .NET framework version to 4.0 for the app pool for your application in IIS.

    Monday, January 5, 2015 6:51 PM
  • User334235778 posted

    To resolve this issue I had to:

    1. Add a section to the <ConfigSections> of the existing web.config file per this resource: https://www.morgantechspace.com/2013/11/The-configuration-section-system-web-extensions-cannot-be-read-because-it-is-missing-a-section-declaration.html
    2. I then made sure to set both ASP.NET v4 entries in the ISAPI and CGI Restrictions application to "Allowed"
    3. Finally, after much experimentation and <g class="gr_ gr_280 gr-alert gr_gramm gr_inline_cards gr_run_anim Punctuation only-ins replaceWithoutSep" id="280" data-gr-id="280">research</g> I also set the SecurityTokenServiceApplicationPool to the .NET v4.0 Application pool.

    The combination of these three things finally allowed us to access our sites again.

    Tuesday, May 8, 2018 8:10 PM