locked
VisualStudio 2010 - Schema Compare - Ignore Object Types is not working properly

    Question

  • I want to compare schema only on tables so when I will want to use Export To Editor it should generate scripts only for the mentioned object types. But when i choose ignore all objects except tables it will show that there are no difference between the source and target on the Tables object type despite the fact that there are differences indeed. 

    Here are the steps that I perform :

    1. New Schema Comparison

    2. select/input source and target connections

    3. Options -> Object Types tab

    4. Select all objects by clicking the "Ignored object types" root node until all the object list is selected.

    5. Uncheck the object which I do want to compare -  Tables

    6. Click OK to close the Options window and OK to start the comparison.

    The result I get is that there are no differences in those objects and not in other objects as well! dispite the fact that I know 100% that there are such differences.

    but when I perform a comparison without going into the Options window it will show differences in these object types. I have tested this many times.

    I'm not sure if its the issue but I did notice that the root node "Ignored object types" checkbox is misbehaving. if I click it twice fast (slower then doubleclick) then it will not effect the child-nodes, if I click on it slower then it does affect the child-nodes, which is very very odd.

    Sunday, August 4, 2013 1:24 PM

Answers

  • Hi Sharikk,

    Sorry for my delay.

    I set a new Environment and repro this issue, I get the same issue as yours, if I only uncheck the object “Tables”, I will get the result like the following screen shot1. But it has the difference in default like the screen shot2.

    But I find that we would uncheck some other options when we uncheck “Tables”, like the “Primary key” and Schemas like the screen shot3, and then I could get the correct result like the screen shot4.

    Sincerely,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, August 13, 2013 11:43 AM
    Moderator

All replies

  • Hi,

    I’m afraid that it is an issue like this thread, could you check the connect report for this issue?

    https://connect.microsoft.com/VisualStudio/feedback/details/661379/schema-compare-wiping-out-ignored-object-types

    Best regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, August 6, 2013 11:09 AM
    Moderator
  • Thank you for your reply....

    I've read this tread before submitting my post. this is not the same issue.

    I never goto/use SQLCMD Variables  and in my case it doesn't clear the selection of the ignored objects, it simply doesn't take them under consideration properly.  it shows me no difference in objects that i know that there are difference and that they were not checked in the "ignored objects types".

    please help 


    Thursday, August 8, 2013 10:06 AM
  • Hi Sharikk,

    I’m doing research on this case, it might take some time before I get back to you. Thanks for your understanding.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, August 12, 2013 5:29 AM
    Moderator
  • Hi Sharikk,

    Sorry for my delay.

    I set a new Environment and repro this issue, I get the same issue as yours, if I only uncheck the object “Tables”, I will get the result like the following screen shot1. But it has the difference in default like the screen shot2.

    But I find that we would uncheck some other options when we uncheck “Tables”, like the “Primary key” and Schemas like the screen shot3, and then I could get the correct result like the screen shot4.

    Sincerely,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, August 13, 2013 11:43 AM
    Moderator
  • Hi Jack,

    Thank you for the great support, it does make perfect sense, although... in this case I would expect a checkbox tree and not a checkbox list, that way the "link" between Table to Schema and Primary Key would be visible and when unchecking the Table it would uncheck the child nodes of the table which in this case Primary Keys and Schema . Furthermore I assume it is not only Schema and Primary Key, its probably also Triggers ect...

    Now that we understand the issue my question to you what about the other objects, like StoredProcedures / Functions / Views , how do I know which other objects should I uncheck inorder to "not ignore" them just as in the table case.

    Thanks

    Sharon

    Wednesday, August 28, 2013 5:41 AM