locked
Redirect HTTP to HTTPS rule results in domain.com redirected you too many times RRS feed

  • Question

  • User1627367597 posted

    Dear all

    I've created a rule using URL Rewrite in IIS 10 and it is proving very frustrating trying to get it to work properly. Basically what we want is that all incoming links to http:// are redirected to our secure https://

    I have followed the recommendations from MS and other SSL sites on how to create this rule. When I enable the rule and try to access the site I am getting an error message in my Chrome browser saying that "This page isn't working. Domain.com rejected you too many times"

    I've cleared the browser's cache and even accessed the website in private mode but still the issue remains.

    I just cannot understand why this could be happening. Could someone please help me solve this issue?

    TIA
    Pierre

     

    Friday, March 5, 2021 9:57 AM

Answers

  • User690216013 posted

    You should post what exactly is the URL rewrite rules you created, because

    • Some rules themselves can lead to such endless redirection.
    • If services like Cloudflare are being used, misconfiguration can also lead to such issues.

    It is recommended that you ask your network administrators to assist, as they know how to analyze further on what might be the cause.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, March 5, 2021 5:30 PM

All replies

  • User690216013 posted

    You should post what exactly is the URL rewrite rules you created, because

    • Some rules themselves can lead to such endless redirection.
    • If services like Cloudflare are being used, misconfiguration can also lead to such issues.

    It is recommended that you ask your network administrators to assist, as they know how to analyze further on what might be the cause.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, March 5, 2021 5:30 PM
  • User1627367597 posted

    Hi Lex

    I am including the rule as per below:

    <rule name="Redirect HTTP to HTTPS" enabled="false" stopProcessing="true">
                        <match url="(.*)" />
                        <conditions>
                            <add input="{HTTPS}" pattern="^OFF$" />
                        </conditions>
                        <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" appendQueryString="false" />
                    </rule>

    We purchased our SSL from GoDaddy and the SSL was installed and binded correctly to our website.

    Any help would be much appreciated.

    TIA

    Pierre

    Saturday, March 6, 2021 3:39 PM
  • User1627367597 posted

    Hi everyone

    This issue was resolved by making a change in the SSL settings of our Cloudflare account. The rule is now working as it should.

    Pierre

    Monday, March 8, 2021 7:54 AM