none
0x80080204 - The specified package format is not valid: The package manifest is not valid

    Question

  • Hi , I'am trying to build a new Version of our universal win 10 app, but I keep recieving the same error 

     

    0x80080204 - The specified package format is not valid: The package manifest is not valid.

    Error info: error 80080204: All app package manifests in a bundle must declare the same values under the XPath *[local-name()='Package']/*[local-name()='Dependencies'].  The values under this XPath declared in the manifest for the package with file name "APPNAME_1.3.31.0_ARM.appx" and package full name "APPNAME_1.3.31.0_arm__IDENTIFIER" at line 11, column 4 don't match those declared in the manifest for the package with file name "APPNAME_1.3.31.0_x86.appx" and package full name "APPNAME_1.3.31.0_x86__IDENTIFIER" at line 11, column 4.

    MakeAppx Build 2

    I need help wee need the new Version by Thursday next week and I'am out of ideas right now, I'have tried a lot but I had no success this far.

    Sometimes i wil build an apxupload file, but only for ARM, the strange thing is that the same project was perfectly fine last week, and I only made a few code tweaks.

    Help would be highly appreciated.


    Thursday, March 3, 2016 3:24 PM

All replies

  • I had a similar problem for awhile and finally deleted all the bin, bundleArtifacts, appx files and obj folder.

    Then I was able to create the packages.

    Monday, March 28, 2016 4:18 PM
  • I had a similar problem for awhile and finally deleted all the bin, bundleArtifacts, appx files and obj folder.

    Then I was able to create the packages.

    Even after deleted still I am having same issue, can you please help on this.
    Thursday, November 10, 2016 2:18 PM
  • The package name that was passing in the command line was different from the name given in the application, I changed the package name to my current package name and it worked
    Thursday, February 21, 2019 12:53 PM