none
gpresult /H rsop.html ERROR: Invalid pointer RRS feed

  • Question

  • Hi,

    We recently have been creating a baseline and rolling various GPOs to our server estate.  I have noticed the following.

    On Windows 2008 and Windows 2012 I get the following error if I run gpresult on the server running cmd as a ADMIN.

    gpresult /H rsop.html  ERROR: Invalid pointer

    when I run cmd as a user I get the report  but only the user configuration.  the computer configuration is

    No data available

     

    When I go to Group Policy Management and run group policy results I get:

     

    An error occurred while generating report:

    Object reference not set to an instance of an object

     

    I have run the command to register .dll and rebooted.  That did not resolve my issue.  Windows 2003 Servers are not affected.

    • Changed type it chick Thursday, October 24, 2013 10:49 AM wrong
    Thursday, October 24, 2013 10:49 AM

All replies

  • Is gpupdate /force command showing any errors? Please provide some information from problem computer's eventlog. Check what cautions or errors appeares after gpresult command in Application and Microsoft\Windows\GroupPolicy logs.
    Sunday, October 27, 2013 10:23 AM
  • Try these 2 options:

    1. Do not provide the file extension. After the report is generated, then give the file an extension, then open in browser. 

    GPRESULT /H GPReport

    If the above does not work, try thisL

    2. Try not running CMD as Administrator it should then bring you to your login user folder and you are able to run the gpresult /h filename.html without the "Invalid Pointer" error.


    Mark D. Albin, M.S. IT Master Services www.itmasterservice.com Office: (775) 229-4254

    • Proposed as answer by Mark D Albin Friday, November 1, 2013 8:53 PM
    Friday, November 1, 2013 8:53 PM