none
MSMQ raised an error message. RRS feed

  • Question

  • Ok so now that I can open a port when my message comes in it is sent to an MSMQ and I get the following error.  I have given the aynomous account rights to the queue as per google searches but still have the below error.

    The adapter "MSMQ" raised an error message. Details "The user does not have permissions to receive messages.

    Please check the queue permissions. ".

    Any assistance woould be appreciated.

    Karl

    Thursday, March 14, 2013 3:37 PM

Answers

  • Hi Karl,

    Try the solutions sugged in this post. People have already discussed about this issue extensively. Some of the suggestions are

    • Ensure the queue format:

    FORMATNAME:DIRECT=OS:<server name>\PRIVATE$\<queue name>

    • set up the permissions for this queue adding the Everyone account with Full Control.

    Go through the post for details.


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.

    Thursday, March 14, 2013 4:18 PM

All replies

  • Hi Karl,

    Try the solutions sugged in this post. People have already discussed about this issue extensively. Some of the suggestions are

    • Ensure the queue format:

    FORMATNAME:DIRECT=OS:<server name>\PRIVATE$\<queue name>

    • set up the permissions for this queue adding the Everyone account with Full Control.

    Go through the post for details.


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.

    Thursday, March 14, 2013 4:18 PM
  • Hi,

    Does the queue exist on the same machine where the receive host accessing the queue is running?

    If yes then like mentioned above please check the queue name and grant access.

    Monday, March 18, 2013 7:11 AM