locked
Rest Resource - Additional Headers not Working RRS feed

  • Question

  • Good Evening,

    Currently we have an HTTP resource that we are using to pull in some API data and we have an API key listed under the additional headers section.  This has been running successfully for a few weeks, but we would like to setup a REST resource to take advantage of the pagination features.

    We have successfully setup the REST connector and the test connection is successful.

    Then when setting up the REST resource, we select the linked service and again it tests successfully.  When we add the API key in the additional headers, the preview data function fails with an "Unknown Error" 

    I know the API key is valid (since its still running on the HTTP resource), but it won't run on the REST resource.  We have tried various combinations to get it to work and it still will not work.

    We even tried using the Copy data wizard, but it won't bring up the schema mapping.  It says "column mapping not initialized"

    We have compared the relevant JSON code and the API-key headers look the same, I even tried to make the REST match the HTTP key, but that didn't work either.

    Has anyone else ran into this problem or have any suggestions?

    Thanks!

    Saturday, March 30, 2019 2:12 AM

All replies

  • Hello SRoberson00 and thank you for your question.

    Are you using a Web activity, or Lookup activity?
    Currently "Lookup activity currently only supports limited functionality for Azure Cosmos DB (MongoDB API), MongoDB and Rest connector.  It will be improved in the future."
    Tuesday, April 2, 2019 9:52 PM