none
Removal of earlier versions of Azure Storage Service APIs

    Question

  • This is regarding the mail we received from Azure saying we have to remove earlier versions of Azure Storage Service APIs as they will not work after Dec 9, 2015.

    Issue: We have configured logs for our Azure storage accounts of our applications to see what versions they are using. We want to know who to access and read these logs from Management Portal without programming.

    Monday, December 15, 2014 4:33 PM

Answers

All replies

  • Hi Rama Karri,

    It is only possible to view the Operational Logs of the Storage account in the Management Portal. 

    Go to "Management Services" in Azure Portal and under 'Operational Logs", you can view the logs of your Storage account and other services hosted. But I don't think so it can provide you the details of REST API version been used.

    As you have enabled logs for your Azure Storage account, All logs are stored in block blobs in a container named $logs, which is automatically created when Storage Analytics is enabled for a storage account. The $logs container is located in the blob namespace of the storage account, for example: http://<accountname>.blob.core.windows.net/$logs. This container cannot be deleted once Storage Analytics has been enabled, though its contents can be deleted.

    Data in the $logs container can be accessed only by using the Blob service APIs, including the .NET APIs provided by the Azure managed library.

    You may refer the following link under "What Should I do?" topic, to know which version is being used by calling the Getblob request.

    http://azure.microsoft.com/blog/2014/08/04/microsoft-azure-storage-service-version-removal/

    Please refer following link for more information: http://blogs.msdn.com/b/windowsazurestorage/archive/2011/08/03/windows-azure-storage-logging-using-logs-to-track-storage-requests.aspx

    Regards,

    Manu Rekhar



    Tuesday, December 16, 2014 7:58 AM
    Moderator
  • Thanks for the reply Manu Rekhar.

    Yes, have already gone thru this article where Azure team sent along with removal notification, and tried accessing logs using the logs container with url http://<accountname>.blob.core.windows.net/$logs (after relacing <accountname> with our our account name) but getting ‘The specified resource does not exist.’ error, also getting the same error when tried to access using logs file name as below.

    https://<accountname>.blob.core.windows.net/$logs/blob/2014/12/15/1800/000001.log

    (When a storage request is logged, the resulting log name correlates to the hour when the requested operation completed. For example, if a GetBlob request was completed at 6:30PM on 7/31/2011, the log would be written with the following prefix:blob/2011/07/31/1800/)

    I have opened a ticket with Azure support team, thanks for your help.

    Tuesday, December 16, 2014 4:12 PM
  • Please let us know how exactly you are trying to access the blob storage.

    If you are directly trying to open the blob storage using the URL in a Web-browser, it is not possible to access in that way. You may use the "Storage Explorer" to access the blob storage account.

    Refer : http://blogs.msdn.com/b/cie/archive/2013/10/10/storage-analytics-logging-how-to-enable-and-where-to-find-the-logs.aspx

    Also, please let know the solution obtained from the Azure Support team in here, so that it can be helpful to others how are facing same issue. Thank you in advance.

    Regards,

    Manu Rekhar

    Wednesday, December 17, 2014 4:26 AM
    Moderator