none
Visual studio hangs when creating Azure App Service from Server Explorer

    Question

  • Whenever I try to create an Azure App Service from inside Visual Studio via the Server Explorer Visual Studio hangs. I also get a message that Visual Studio is waiting for an internal operation to complete.

    The "Create App Service" window shows up and a generic Web App Name is added however the circles next to Web App Name textbox (that I assume should turn into a green check-mark) is frozen and I can't edit or do anything in the window. The entire window is completely frozeon. The only way to exit this state is by killing Visual Studio.

    This issue is happening on both Windows 7 and Windows 10, both with Visual Studio 2015 professional, both with Azure SDK 2.8.1

    Friday, December 4, 2015 9:46 AM

Answers

  • Fixed it by adding a new Web App via Azure portal. After this was added I could add new Web Apps from within Visual Studio Server Explorer.

    I could also delete all the resources associated with this Web App (Resource Group, App service plan etc.) and the Window still does not hang.

    So in short summary, the fix appears to be to at least once before create a Web App via the portal.

    • Marked as answer by AndreasWass Friday, December 4, 2015 10:40 AM
    Friday, December 4, 2015 10:40 AM

All replies

  • Fixed it by adding a new Web App via Azure portal. After this was added I could add new Web Apps from within Visual Studio Server Explorer.

    I could also delete all the resources associated with this Web App (Resource Group, App service plan etc.) and the Window still does not hang.

    So in short summary, the fix appears to be to at least once before create a Web App via the portal.

    • Marked as answer by AndreasWass Friday, December 4, 2015 10:40 AM
    Friday, December 4, 2015 10:40 AM
  • Glad to know that you have resolved this issue, thanks for sharing your solution here! AndreasWass:)

    Have a nice day,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, December 8, 2015 5:21 AM
    Moderator
  • Your solution is bigger time saver to me, thanks for figuring it out.
    Tuesday, December 15, 2015 9:11 PM
  • Jack,

    I am having the exact same issue and the workaround posted does not work for me. I am unable to create a new web application that is hosted in Azure.

    I am assuming that since this seems to be a defect that it is being fixed? Where would I be able to track the issue?

    Regards,

    Nick Munday

    Monday, December 28, 2015 9:40 PM
  • Hi Nick,

    >>I am having the exact same issue and the workaround posted does not work for me.

    Different possible reasons which would generated the similar result.

    >>I am unable to create a new web application that is hosted in Azure.

    Do you mean that you can't add a new Web App via Azure portal?

    If so, I doubt that the real issue would be not related to the VS IDE, we would think about the Azure portal or others.

    Since it is related to the Azure web app, if possible, you could post this issue to the Azure App Service - Web Apps forum, there you would get dedicated support.

    https://social.msdn.microsoft.com/forums/en-us/home?forum=windowsazurewebsitespreview

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, December 29, 2015 2:53 AM
    Moderator
  • Jack,

    My issue is the same as the Andreas. Inside VS2015 trying to create a new project and hosting it in azure. Which brings up the 'Create App Service' dialog. At this point I cannot click on anything in the dialog or VS. I have to kill the process. I have attached image of the dialog to be clear. Well I tried to attach image but the forum says I have to verify my account first. I also get the "Microsoft Visual Studio Is Busy" notification over and over again.

    Regards,

    Nick Munday

    Thursday, January 28, 2016 8:42 PM
  • Hi Nick,

    Since this thread was closed for a few days, would you mind opening a new case in this forum? Our members would follow up your question in time:)

    Sincerely,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, January 29, 2016 2:52 AM
    Moderator
  • I'm having a similar issue, so I'm already posting this here. Next I'll search for the a newer thread about this:

    When I create a new project, or even with an existing project, I try to publish it to Azure.

    The Create App Service Dialog opens, I'm able to select the correct subscription, and then the Dialog and VS just hangs.

    This must be the worst implementation of a plug-in. Running completely on the VS UI thread, doing some blocking call and silently crashing?

    Wednesday, February 3, 2016 8:27 AM
  • I am now experiencing the same problem as well: During the project creation workflow the Visual Studio instance just hangs after the Create App Service Dialog has opened.

    Until a few weeks ago everything went fine. I just installed ASP.NET Core RC2, but I am not exactly sure if this is related.

    The only way to work around the issue is to really leave the "Host in the cloud" checkbox unchecked as far as I know.

    Monday, June 13, 2016 2:09 PM
  • I'm also having this problem and would agree that the only way around it is to leave the checkbox unchecked
    Friday, September 2, 2016 9:39 AM
  • I'd like to chime in her as well.  Same issue.  VS hangs in Create App Service dialog.  VS 2015 Enterprise w/ Update 3 running on Windows 10.  Seems to be a common problem, and has gone on at least seven months with no resolution.  What actions are being taken to investigate this?
    Monday, September 12, 2016 1:01 PM
  • +1 for me; I am also still experiencing the issue; i.e. the Create App Service dialogs hangs while retrieving (if at all!) the available App Service Plans. The rotating icon is not rotating, it is frozen.

    OS: Windows 7

    Visual Studio edition: Visual Studio Community 2015 Update 3 (14.0.25431.01)

    .NET version: 4.6.01055

    Azure App Service Tools: 2.8.1 (14.0.11123.0)

    UPDATE: Just installed Azure App Service Tools 2.9.5 and the problem went away! Good work!


    Wednesday, October 5, 2016 9:32 PM
  • Same problem here in two computers (one Windows 7 and other Windows 10)!

    Visual Studio 2015 Update 3 hangs when trying to host in Azure, even after adding a Web Service in the portal.

    Tuesday, October 18, 2016 2:38 PM