locked
RMS Related Commands Returns 405 (Command Not Allowed) Status RRS feed

  • Question

  • Here are the commands I am sending to the Windows 10 Device.

    <Replace>
    			<CmdID>eddb1f7d-3600-4cba-b004-075d009290c6</CmdID>
    			<Item>
    				<Target>
    					<LocURI>./Device/Vendor/MSFT/EnterpriseDataProtection/Settings/RMSTemplateIDForEDP</LocURI>
    				</Target>
    				<Meta>
    					<Format xmlns="syncml:metinf">chr</Format>
    				</Meta>
    				<Data>718ae9c7-7a36-40e5-b64b-4dfa073d90be</Data>
    			</Item>
    		</Replace>
    		<Replace>
    			<CmdID>f8fa23db-bf26-44d1-85e6-1a652d570e57</CmdID>
    			<Item>
    				<Target>
    					<LocURI>./Device/Vendor/MSFT/EnterpriseDataProtection/Settings/AllowAzureRMSForEDP</LocURI>
    				</Target>
    				<Meta>
    					<Format xmlns="syncml:metinf">int</Format>
    				</Meta>
    				<Data>1</Data>
    			</Item>
    		</Replace>

    I am getting 405 status as follows.

    <Status>
    			<CmdID>3</CmdID>
    			<MsgRef>6</MsgRef>
    			<CmdRef>eddb1f7d-3600-4cba-b004-075d009290c6</CmdRef>
    			<Cmd>Replace</Cmd>
    			<Data>405</Data>
    		</Status>
    		<Status>
    			<CmdID>4</CmdID>
    			<MsgRef>6</MsgRef>
    			<CmdRef>f8fa23db-bf26-44d1-85e6-1a652d570e57</CmdRef>
    			<Cmd>Replace</Cmd>
    			<Data>405</Data>
    		</Status>

    Could anybody help me out, How to set RMS related settings ?

    Thanks.

    Friday, February 17, 2017 7:32 AM