none
Nano Server- WOW64 - Program 'setup.exe' failed to run: The subsystem needed to support the image type is not present. RRS feed

  • Question

  • Hi All,

    I have Successfully Deployed NANO Server on Hyper-V. When i trying to run a 32-bit setup.exe file then it is giving error as :

    Program 'setup.exe' failed to run: The subsystem needed to support the image type is not present.
        + CategoryInfo          : ResourceUnavailable: (:) [], ApplicationFailedException
        + FullyQualifiedErrorId : NativeCommandFailed

    Later i have found this is with respect to  ServerCore-WOW64 or SysWOW64 ( Nano server). My question : Is there any way to install my required application on Nano server ?

    Thank You,

    Yarra Omkar

    Wednesday, February 24, 2016 6:11 AM

Answers

  • Nano only runs 64-bit binaries. Removing all the 32-bir support was one of the optimizations MSFT made to make Nano as small and simple as possible. See https://technet.microsoft.com/en-us/library/mt126167.aspx
    Sunday, February 28, 2016 3:39 PM

All replies

  • Nano only runs 64-bit binaries. Removing all the 32-bir support was one of the optimizations MSFT made to make Nano as small and simple as possible. See https://technet.microsoft.com/en-us/library/mt126167.aspx
    Sunday, February 28, 2016 3:39 PM
  • Hi Ender Barillas,

    Yes, I agree,but few applications we are using past few years are on 32-bit platform based applications which also run on 64-bit platform OS. I want to implement NANO Server for my usage.  Is there any alternative to install additional packages to get install my application ?

    Thank You,

    Yarra Omkar.


    yarra omkar

    Thursday, March 3, 2016 2:41 PM